tried adding another drive, now original wont show

Discussion in 'PowerPC Macs' started by G4Simon, Jan 31, 2013.

  1. G4Simon macrumors newbie

    Jan 31, 2013
    Leeds UK
    Hello Mac People
    this is my first post so hi to everyone

    Ive got a 933 quicksilver, been running OS9 on it as I use old music programs (ProTools).

    Today I decided to add another drive since space was getting tight. So I installed this "120GB Maxtor Plus 9" into the 2nd slot above the original 120GB Hitachi Deskstar.

    Ive tried all the different jumper combinations for both drives but I now cannot see my original drive, even if I put the mac back the way it was before attempting to add the new drive, it will not show up, when I press alt on boot up I just get the flashing question mark.

    When I boot up from Diskwarrior (bootable 3.03), Diskwarrior will see the Deskstar drive no problem, Ive rebuilt the directory on all 3 partitions of the original deskstar with Diskwarrior but still when I boot I get a question mark. If both drives are connected and I boot from Diskwarrior, again both drives and all partitions are seen by Diskwarrior no problem

    Ive got the ribbon cable set up as it should be ie:
    blue end to MB
    black connector to master
    grey connector to slave

    when I look at the Diskwarrior GUI its telling me my original deskstar (sys disk) has the following Device IDs:

    original deskstar has 3 partitions:

    "Macintosh HD"--- (OS9.2.2) Device ID: disk1s12
    "OSX (10.3.9)"--- Device ID: disk1s10
    "Audio" (data) ---Device ID: disk1s14

    original deskstar is listed as Master in the Diskwarrior GUI under the Hardware Tab

    the added new Maxtor

    has 2 partitions

    "MacHD2"--- Device ID: disk0s9
    "New2"--- Device ID: disk0s10

    this Maxtor is listed as Slave in the Diskwarrior GUI under the Hardware Tab

    Ive zapped the PRAM a few times and the MB button SVRAM

    still no luck

    do these Device IDs look suspect to anyone? Could they be the problem? Why would the Deskstar have such high numbers for its ID??

    One other thing I'm thinking could be the problem is I'm sure the motherboard battery might be dead as I do get the clock going back to 1974 on boot ups sometimes but not always, I thought maybe the PRAM is not resetting properly because of the possible flat MB battery.

    Anybody any ideas what could be the problem here? been googling this all day and have read numerous threads on it :confused:

    Sorry for the long post but just wanted to convey what ive tried so far

    Well I hope someone can shed some light coz I'm stumped and beginning to bang my head against the wall:)


  2. eyoungren macrumors Core


    Aug 31, 2011
    ten-zero-eleven-zero-zero by zero-two
    Don't know if it would help, but you might try resetting NVRAM. Don't have the link for that right now, but it's easily findable on Google.

    I hate IDE issues! Sometimes, the best thing you can do is start over.

    I'd pull the cable from both drives and restart the Mac with the cable disconnected. Shut down. Plug the master drive back in using the original jumper cable settings. Hopefully that gives you your main drive back. If it does, shut down again and then try adding the second drive back on.

    I'd use a Master/Slave jumper setting on the respective drives. Try that first before you try Cable Select on both. If nothing works, then I don't really know what to say. I supposed there's a way you could reassign the drive IDs, but IDK. IIRC, disk0sXX would indicate a master drive and disk1sXX would indicate a slave drive, but don't quote me.
  3. jodelli macrumors 65816


    Jan 6, 2008
    Windsor, ON, Canada
    It does look as if your onboard battery is getting hinky. In which case you'll never see a consistant power up configuration. And those batteries aren't expensive.
    I'm not saying that's the total solution but it needs to be done at some point. I replaced one on a Sawtooth I'd mod rodded a few years back.
  4. G4Simon thread starter macrumors newbie

    Jan 31, 2013
    Leeds UK
    tried setting the joy

    located a 10.3 retail disk, started up with that with just the Deskstar connected and the installer sees all 3 partitions, quit the installer and started disk util which also sees the 3 partitions, repaired the OSX partition (no problems found) and selected that as the startup disk, restarted and still got a question mark, restarted again holding alt and again nothing but a question mark

    this makes no sense at all:confused:

    If Ive tried both master and cable select on the deskstar (on its own) that has to rule out jumpers

    If Diskwarrior and disk utility report no problem that should rule out directory issues

    tried 2 different ribbon cables, tried plugging the Deskstar into the ATA bus for the superdrive

    A flashing question mark is all i get for my trouble:mad:

    these high ID numbers are still bugging me, what else can it be?

    gonna nip down and get a new battery see if that makes any difference
  5. G4Simon thread starter macrumors newbie

    Jan 31, 2013
    Leeds UK

    everything now working:D

    for anyone who has any problems like this, then what I write below may help

    I connected both drives as "cable select"

    booted up from a OSX 10.2.6 retail DVD

    I then partitioned the Maxtor drive to be the same as my Deskstar

    installed a new OSX10.2.6 on the Maxtor OSX2 partition

    once booted from the new Maxtor OSX2, I could then see all drives but I could only boot from the new maxtor OS

    I then copied my original 9.2.2 to the Maxtor OS9 partition

    I then booted up from a OS9 retail disk (holding C)

    I then reinstalled (not a clean install) OS9 over the Maxtor OS9

    I then restarted holding alt and to my surprise all the partitions were listed, I only expected to see the Maxtor OS9, I chose my original Deskstar os9.2.2 and it booted up:D

    thanks to the posters who tried to help...respect:)

Share This Page