Tried everything! apps still wont open!!! Ahh help!!!

Discussion in 'iPod touch' started by jadamcyk, Jan 7, 2010.

  1. jadamcyk macrumors newbie

    Joined:
    Mar 25, 2008
    Location:
    Chicago, IL
    #1
    Just bought an ipod touch 3rd gen running 3.1.2 and apps worked for a week until yesterday. They all crash immediately once i try to open them...

    I tried the following...

    Reinstalling apps...failed
    Restoring firmware...failed
    Re-syncing each app from itunes...failed

    I'm debating whether to try whipping it at a wall but not to that point of frustration yet... any ideas?!?!?!

    thanks in advance.
     
  2. Penguissimo macrumors 6502a

    Penguissimo

    Joined:
    Nov 17, 2009
    Location:
    Michigan
    #2
    When you restored the firmware, did you choose to restore from a backup or set it up as a new iPod? If the former, try the latter.
     
  3. jadamcyk thread starter macrumors newbie

    Joined:
    Mar 25, 2008
    Location:
    Chicago, IL
    #3
    I set up as a new iPod, I'll try restoring from a backup when I get out of work. It seems like a lot of people are having this problem
     
  4. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #4
    Try downloading a free app directly to your device via wifi, sometimes this can be an authorization problem and downloading an app will require you to enter your account info which can clear up the problem.
     

Share This Page