Tried everything. Still no continuity.

Discussion in 'OS X Yosemite (10.10)' started by dillschu, Oct 1, 2014.

  1. dillschu macrumors newbie

    Joined:
    Sep 29, 2014
    #1
    Hello! I have an iPhone 5s on iOS8 and a 2013 MBAir on Yosemite.

    Bluetooth is turned on on both
    They're both on the same wifi network
    They're both logged in to the same iCloud account
    The "Handoff" and "iPhone cellular calls" buttons are both on on the phone
    The "Allow Handoff" button in settings and the "iPhone cellular calls" button in FaceTime is on on the computer

    I've tried
    Logging into and out of iCloud and restarting both devices
    Turning bluetooth on and off
    Testing bluetooth by sending files back and forth
    among other things

    When I send SMS texts from my iPhone they don't show up on the Mac, and I can't send SMS from the messages app on the mac
    Also, weird things are happening.
    After the iOS8 update, I've noticed a few times when I'd been sending iMessages from the Mac, and when I go to my iPhone they show up as being sent as SMS. How does that make any sense?
    I've also sent iMessages from my iPhone, then they don't show up at all on Messages on the Mac. The received iMessages show up, but not the ones I'd sent.
    I've had some texts show up on the phone as being sent as SMS, then on the Mac it says they were sent as an iMessage.

    When I get a call on my phone, it'll show up on my Mac and it'll ring, but it bugs out whenever I try to answer it so it's never successfully worked. Same thing happens when I try to start a phone call from the Mac

    My phone's network used to show up as an option to connect in the Mac's wifi menu, but recently since I've been messing with things I haven't seen it show up anymore. When it did show up it could never connect, though.

    I've never seen the little "bouncing icon" or the other handoff icons on either device.

    I don't know what else could be wrong or what else I could do to try to diagnose/resolve this. I'm turning to you, fellow Apple nerds. Any help would be greatly appreciated.
     
  2. dillschu thread starter macrumors newbie

    Joined:
    Sep 29, 2014
    #2
    Update: someone told me Theyve been receiving my texts as coming from my email address rather than my phone number.

    Any help would be greatly appreciated...
     
  3. BasicGreatGuy, Oct 2, 2014
    Last edited: Oct 2, 2014

    BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    In FaceTime preferences, make sure your phone number is listed first under the "start new calls from" option.

    Edited to add: You also need iOS 8.1 beta and the latest Yosemite release to do SMS relay.
     
  4. Inhalant macrumors member

    Inhalant

    Joined:
    Mar 12, 2014
    Location:
    Calgary
    #4
    I am with you there. It simply will not work! If somebody has a solution, I could use it....
     
  5. dillschu thread starter macrumors newbie

    Joined:
    Sep 29, 2014
    #5
    Just checked, it is listed first.

    And I just have 8.0.2 but even if the relay isn't up and running I should still be able to use other aspects of continuity right? This isn't he only part not working right.
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #6
    Outside of SMS relay, the other features should work, provided your Mac is new enough etc.
     

Share This Page