Tried three times to install Mojave

Discussion in 'macOS Mojave (10.14)' started by swandy, Oct 5, 2018.

  1. swandy macrumors 6502

    Joined:
    Oct 27, 2012
    #1
    I have a late 2015 iMac Retina 4K machine and have NEVER had the issues with any MacOS updates or new versions of MacOS that I am having trying to get Mojave to install.
    First two attempts it would get to the Choose Light/Dark screen, take FOREVER to get to the Log In screen, then both the BlueTooth Magic Keyboard 2 and Magic Mouse 2 would not work. Got a USB Wireless mouse to be seen and the first time I plugged in the Keyboard to USB and thought it was still not being seen. Ended up rebooting and going back to HS. Second attempt same crap but then realized the keyboard (when plugged in) was being seen BUT the keystrokes were taking forever to be recognized. Eventually (and somewhat patiently) I got logged in and still the two BlueTooth devices would not cooperate and apparently my Wifi Hardware disappeared! Another reboot and reinstall of HS.
    Today tried booting to Safe Mode in HS and made third attempt. Well the installation went through smoothly and now the keyboard/mouse Bluetooth issues were gone. Still no Wifi and everything I clicked on took FOREVER to be recognized. Added a new issue that both my external HDs (one for my Photos and iTunes libraries and one for Time Machine) were not recognized. Went back to HS for a third time.
    Any other suggestions besides either doing a clean install (not that anxious to play with Mojave to go through that) or just wait until 10.14.1.
    Thanks for reading, Steve
     
  2. Isamilis macrumors 6502a

    Joined:
    Apr 3, 2012
    #2
    Have you tried reset SMC and PRAM before the update?
     
  3. swandy thread starter macrumors 6502

    Joined:
    Oct 27, 2012
    #3
    No but I have heard that mentioned. Will try that - if and when I decide to make another attempt. Thanks.
     
  4. swandy thread starter macrumors 6502

    Joined:
    Oct 27, 2012
    #4
    Ok. Tried it and the installation went through. Now the Bluetooth issue with the mouse/keyboard was gone but the no WiFi hardware was still not solved - even after an additional reboot and the sluggishness of how the system now reacts to mouse clicks is very annoying. Going back to HS. Mojave was not ready for prime time IMHO
     
  5. lynmond macrumors newbie

    Joined:
    Jan 13, 2011
    #5
    I have the same iMac....currently running Sierra. Your experience confirms my own rationale for not upgrading as I genuinely do not trust APFS running on Fusion drives...at least yet.
     
  6. swandy thread starter macrumors 6502

    Joined:
    Oct 27, 2012
    #6
    Have never this type of issue with any previous MacOS updates so very surprised.
     
  7. MapleGrove macrumors newbie

    MapleGrove

    Joined:
    Mar 30, 2014
    Location:
    The Berkshires
    #7
    I'm having the same issues with my 2017 iMac.
     

Share This Page

6 October 5, 2018