Tried to Jailbreak, too hard, gave up, don't bother.

Discussion in 'Jailbreaks and iOS Hacks' started by TheSpaz, Aug 13, 2008.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    Last night I decided I wanted to jailbreak my iPhone. PwnageTool worked nice, but when I restored all of my App icons reset to the default springboard locations. I didn't care much because I knew where they were, but then iTunes started syncing all of my Apps on my computer... so while it was doing that, it was erasing the ones I already had on my iPhone... great. I didn't sync my Apps before... I did all of my installs and uninstalls right on the iPhone. Anyways... after I got that all sorted out, I tried SSHing into my iPhone (because OpenSSH was installed) and it wouldn't let me! I typed in the ip address correctly and I used root as the user name... I also used the default "alpine" password and it refused to let me connect. Yes, I understand it takes a few minutes on the first connect, but it would disconnect immediately after I started. To make a long story short, (too late), I unjailbroke my iPhone and restored with the official firmware and restored to a backup that was made before I jailbroke. By the way, my springboard layout still didn't go back to the way I had it... they were all mixed up. Then iTunes refused to NOT sync my Apps. If I unchecked sync Applications, it just erased all of my Apps. Anyways, all is back to normal, I guess I'm just going to sync my Apps from now on. This makes me wish I never decided to try and jailbreak. It used to be so easy *sigh*.
     
  2. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #2
    If you jailbroken b4 and ssh, its prbly the identification thats messed up. when your computer SSH into any other device, it leaves an identification key. When you install a new firmware, the Identification Key changes and therefore it seems that you can't ssh into it anymore. On a mac its in ~/Users/username/ssh/ and you can delete the file. I dunno about windows, sorry.

    If loosing an application was a problem, you can always redownload them to your computer for free. However, it was mostly inevitable since you're basically reseting the whole system by jailbreaking.

    I'm sorry that you felt like Jailbreaking 2.0.1 was difficult and frustrating. I thought JB 2.0 was easier than JB 1.1.4 (but then again i had to go through the hard methods w/o iLiberty, ziphone, pwnagetool and stuff)
     
  3. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #3
    It wasn't a key identification thing. I've never jailbroken this device before. I thought I was going to be able to pwn, restore and restore my backup and everything was going to be the same except for the Cydia icon. I never thought it was going to completely screw up everything. I'll just use it un-jailbroken for now... I only wanted to jailbreak to change the icons of apps that I didn't like.
     
  4. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #4
    Hmmm... Went perfectly for me. Selected my phone, told it to install ssh. Pwnd. My apps were all unsorted after I set it up like a new phone, but then I got them back in the right spots. SSH worked perfectly. I just waited until I had finished syncing. Don't know if it matters, I don't think so.
     
  5. iphonics macrumors member

    Joined:
    Aug 4, 2008
    #5
    seriously jailbreaking is a piece of cake!! did you make sure you were using SFTP while trying to SSH?? renewing/refreshing your wireless network IP sometimes works.
     
  6. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #6
    I'm not new to this jailbreaking thing. I've jailbroken every version of the OS since the launch of the iPod touch. I've SSH'd hundreds of times, I know how to do it. It just wouldn't accept my password. I was on the same network, using the correct IP. Connecting as root with password alpine. It just didn't work. The iPhone showed that OpenSSH was in fact installed.
     
  7. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #7
    The itunes app issues is nothing to do with the jailbreak.

    It is a buggy itunes that does that.

    Its best to NOT sync your apps at all as it deletes them then tells you to update them and then updates them then deletes them etc... Apple should sort it out as it is a huge pain.

    It would happen anytime you restore or re-sync if you have sync applications on!

    As for SSH - it is probably best if you download it after you have jailbreaked instead of install it straight to the phone.

    However connection issues are normally fixed by rebooting the phone 2-3 times as has always been the case. Some people claim it will work immediately and it does but every jailbreak method previously told us to reboot several times to ensure SSH was working properly so that is the best course of action.
     
  8. mcdj macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #8
    SSH didn't work for me until I installed Boss Prefs and toggled SSH a few times.

    But then I ditched the whole affair anyhow.
     
  9. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #9
    oops. i forgot to mention.
    if somehow the IP address had another device sshed into it before (many routers doesnt set IP address to a specific device each time), and u try to ssh into another device that uses the same ip address, then the identification key changes as well.

    say u have 1 ipod touch and 1 iphone, (this happened to me quite a few times b4 i sold my ipod touch)

    my ipod touch for some reason would go on
    192.168.1.4
    192.168.1.5
    192.168.1.8
    192.168.1.9

    at randomly depending on how many comps are connected and online.

    my iphone always uses
    192.168.1.5
    192.168.1.9

    so if my ipod touch connected once w/
    192.168.1.5
    or
    192.168.1.9
    then i tried to connect w/ iphone, it wont connect unless i erase all the key identification (since the computer already remembers the imprint of the ipod touch)

    this is for future use but if it ever fails to connect, try ssh using terminal or cmd prompt.
    type:
    ssh ipaddress
    and it'll tell u whats wrong if it couldn't connect.
     

Share This Page