Tried to upgrade to 10.7 on my 10.6.8 - kernel panic after first restart :( Anyone?

Discussion in 'Mac OS X Lion (10.7)' started by larscph, Jul 23, 2011.

  1. larscph macrumors newbie

    Joined:
    Jul 23, 2011
    #1
    Hi - I just bought, downloaded and started the install of 10.7 Lion on my MacBook Pro 17 inch Core2 Duo laptop. Purchase and download went with no problems, install started fine with a warning about that my old Time Machine backups would become useless after the upgrade. All good.

    The installer startes and after a few minutes it needs to reboot the computer, which then ends up is this nasty message

    -----
    "devfs_kernel_mount: faild to find directory '/dev', 2 panic (cpu 0 caller 0x47f5ad): "Proces 1 exec of /sbin/launchd failed, errno 2\n"@/SourceCache/xnu/xnu-1504.15.3/bsd/kern/kern_exex.c:3145

    Debugger called: (panic)

    (then a backtrace)

    BSD Proces name corresponding to current thread: init

    Mac OS Version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3-1/RELEASE_I386
    System model name: MacBookPro5.2 (Mac-F2268EC8)

    System uptime in nanoseconds: 1458886583
    -----------


    If I try to power off/on the same message reappears.

    What a nice way to trash my computer!

    Are there anybody in here who has a clue to what that is about? Also, are there any way to get this thing into some sort of "safe mode" where it could try to recover *without* using the Snow Leopard installation media which I just happened not to have by hand... I have a another MacBook, though - where I am writing this on....

    Any help / suggestions greatly appreciated.

    Lars
     
  2. larscph thread starter macrumors newbie

    Joined:
    Jul 23, 2011
    #2
    At least I got my system back alive - held back alt/option and chose my hard drive rather than the Mac OS X install drive that the installer appears to have created. At least that is a bit better :p

    However, the other error is really strange.... Are there any of you guys who have had that?
     
  3. karembou macrumors newbie

    Joined:
    Jul 26, 2011
    #3
    Same issue

    Downloaded OS X Lion, then it started to load up the files then it restarted. Once right after the restart it gave the panic kernel screen. Went to the Mac Store over at the Genius Bar and they tried it over there after after formatting my macbook and reinstalled os x snow and updated to 10.6.8 and then ran the OS X Lion installation, it gave the same error. He simply told me that the hard drive is the problem. I gave him a weird face look and left cause I recently replaced my hard disk 2 months ago ?? Anyway, I have another hard disk and will replace the existing one and see what will happen.

    Anyone, had any chance of figuring it out, then I'm all ears :)

    Karembou
     
  4. larscph thread starter macrumors newbie

    Joined:
    Jul 23, 2011
    #4
    That sounds strange... I will try to get a hold of Apple too and hear what they have to say. What sort of hard drive do you have in your Macbook? I too have a replaced drive as the original 320 GB drive broke down at some point.

    I have the Seagate Momentus XT 500 GB hybrid-drive in mine - maybe it is incompatible in some way?
     
  5. larscph thread starter macrumors newbie

    Joined:
    Jul 23, 2011
    #5
    Working now!

    I got it working now... I rebooted to the OS X Snow Leopard installation DVD and performed a disk repair on the disk in the MacBook. It found an error - incorrect count of files and directories. I corrected that and restarted again holding down the ALT key. Then I chose the Mac OS Installation again - and voilá - it worked.
     
  6. Picoman macrumors newbie

    Picoman

    Joined:
    Mar 1, 2010
    Location:
    Fife
    #6
    I was getting the same kernal panic screen, now im not even getting that far anymore, 1 hour of spinning so far.

    My HDD disk verify fails.
    HDD repair fails.
    Unmounts itself and won't mount again without resart.
    Cant back up HDD, Restore fails after 30 seconds.

    I have tried repairing disk from Snow Leopard cd, but cant see how to do that, just goes through the same thing.
    I have an External HDD Lion Installer partition.

    It wont let me Download and Install onto a partition bcoz it is not GUID and it cant be modified. It shares same HDD as TM backups. ><

    Currently installing Lion by downloading from the options at start up onto another HDD that i had to wipe... Had some stuff i really needed to keep but ah well.

    Has Apple just broken my laptop so i spend 2k on a new one?
     
  7. climb08 macrumors newbie

    Joined:
    Jan 31, 2012
    #7
    Similar problem but I have worse

    ok...my dad was stupid when i first got my mac and partitioned the hard drive without knowing what he was doing, I am trying to fix it but normal methods dont work as it is such a mess.

    Tried to restore my computer to factory settings, by reinstalling the disks it came with, been trying on what I assume to be the main hard drive for a few hours now and getting this message... tried it twice then found the option to erase what was on there previously so went for that but same problem, tried restarting in safe mode, nothing happened, tried resetting things holding down a number of buttons, volume went up, but nothing else positive...

    Now trying to install in erasing everything from the Bootcamp hard drive as they seem to be a bit mixed up and maybe the old software is actually on there...

    New problem, the screen has just stopped lighting up, i dont know why, i hope its temporary...

    going to have to wait another few hours to see if this works...any ideas?
     
  8. robertbrian23 macrumors member

    Joined:
    Oct 7, 2010
    #8
    same issue with me guys.

    here is my story. my 1 year old son, knock off my mbp from a small chair and viola OS X lion won't work. tried the disk utility but can't repair disk. installed a OS X snow leopard on my firewire xHD then repair disk on the MBP HD and it works. but upon installing OS X snow leopard got 'installation error'. try the lion recovery after 5 hours downloading it again it just hangs after several hours. then tried the copy the installers and put it in a USB still won't work. got a bootcamp partition to check the net for resolutions by the way. :)

    have the usb thumb drive and got the kernel panic error. :S

    please help. hope someone has a resolution.

    my last resort once my wife's netbook is fix, she'll have a windows xp. the remove the partition on my mbp and run clean install of OS X lion.

    did anyone try the clean install? remove all partition option?

    or just pure hard disk issue? please advise.
     
  9. Dark Goob, Sep 28, 2015
    Last edited: Sep 29, 2015

    Dark Goob macrumors regular

    Dark Goob

    Joined:
    Jun 6, 2007
    Location:
    Portland, OR
    #9
    I zapped PRAM by turning the machine all the way off, wait 10 seconds, hold command-option-P-R, then turn on while holding that and wait until the Mac has restarted twice... that fixed this problem for me
     

Share This Page