Tried using boot camp, now can't boot into snow leopard

Discussion in 'Mac Basics and Help' started by Youngy34, Oct 24, 2009.

  1. Youngy34 macrumors newbie

    Joined:
    Aug 31, 2009
    #1
    Ok I've lurked on this site for a while but not really posted much at all, however I now need some help.

    I bought windows 7 professional for £30 using my student email. However it seems you need to have windows already installed as it is an upgrade (although it does say you can do a fresh install...). I'd already partitioned my drive so I deleted that partition realising I couldn't install it straight on.

    So as I'm back from uni I started up bootcamp and created a 32gb partition and inserted my xp disc (you can create an iso from the upgrade disc with windows apparently, couldn't get it to on mac). Everything went fine except when I got to the part where you select what partition to put xp on. There was only one there and it was alot bigger than 32gb. So I cancelled the installation and my macbook restarted.... osx didn't boot. In a bit of a panic (I don't have my sl restore disc with me) I booted up the xp cd again and tried completing the installation. It said it finished but now when the macbook boots it just shows a flashing folder with a ? in it.

    Obviously when I get my restore disc back I will put that in, but will I have to completely re-install snow leopard and lose my data? Theres nothing important on it but I'm worrying about whether it'll be an easy fix or not, and obviously I'd rather not lose my stuff. What do you think?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    What happens when you hold the option key on startup?
     
  3. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #3
    You know what real estate say's, location, location, location. In the computer world it's, BACKUP, BACKUP, BACKUP...
     
  4. Dan73 macrumors 6502a

    Joined:
    Jul 30, 2009
    #4
    Try this.
     
  5. Youngy34 thread starter macrumors newbie

    Joined:
    Aug 31, 2009
    #5
    haven't backed up yet as its a new mac and pretty much all that's on there is applications which I can download again. It's just more annoying than anything.

    When I hold the option key I just get a white screen with the pointer, the flashing ? folder doesn't appear.
     
  6. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #6
    It sounds as if you have managed to overwrite the OSX partition when you tried to install XP - the clue was in the fact that you said that the size of the partition you selected "was a lot bigger than 32GB".

    So now you have no OS at all - start again with your SL install disc and reformat the entire drive to GUID before you start the install.

    Once you have SL on the machine use the BootCamp assistant to create the 32GB partition and follow the instructions to install XP...

    Seems odd that you don't have a flashing folder on start-up though.
     

Share This Page