Trim Enabler won't stay on!!!

Discussion in 'Mac Pro' started by Flocarino, Sep 22, 2012.

  1. Flocarino macrumors member

    Flocarino

    Joined:
    Jun 4, 2010
    Location:
    Montreal, Canada
    #1
    I use Trim Enabler with my Crucial M4 256GB SSD until now for a few weeks but today I noticed that Trim Enabler was turned off, I switched it back to on, entered the password but it automatically goes back to off, it simply won't stay on.
    What should I do?
    Does it have anything to do with the OS upgrade 10.8.2 ?

    Thank you
     
  2. Lance-AR macrumors 6502

    Joined:
    May 7, 2012
    Location:
    Little Rock, AR
    #2
    I always have to turn it back on plus reboot after updating.
     
  3. = bluntman = macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Toronto, Ontario
  4. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #4
    Hello Flocarino

    The Trim patch is reset on system updates, this is normal and working as intended as it allows for the Trim driver to be updated.

    However, there is a slight hiccup problem with the slider component that occurs for a few people in Mountain Lion.

    What I'd like you to do is, go to System/Library/Extensions. Find the IOAHCIFamily.kext and copy it to desktop. Zip it, and email to info[at]cindori.se. Also, go to your Software folder, there is a folder called Utilites with an app called System Messages (native OSX application, should work to spotlight search for it too). Open it and also look what log output is written when you try to enable Trim inside Trim Enabler. Attach the output in your email.

    regards,
    Oskar / author of Trim Enabler
     

Share This Page