Triple boot (OS X, Windows XP, Ubuntu) issue

Discussion in 'macOS' started by chriswcs, Jul 13, 2011.

  1. chriswcs macrumors newbie

    Joined:
    Jul 13, 2011
    #1
    Hello all. If this is in the wrong section, I apologize to the Mod - feel free to move it.

    Basically, I have every OS installed, but not even Refit will load my other partitions. I can boot into OS X 10.6, but neither Windows nor Linux show up.

    I'm on Macbook Gen 6, if that matters, and here is my disk information:

    Code:
    diskutil list /dev/disk0
    
    /dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *250.1 GB   disk0
       1:                        EFI                         209.7 MB   disk0s1
       2:                  Apple_HFS SAUCIN                  169.6 GB   disk0s2
       3:       Microsoft Basic Data WINDOWS                 55.0 GB    disk0s3
       4:       Microsoft Basic Data LIN                     20.0 GB    disk0s4
       5:       Microsoft Basic Data SWAP                    5.1 GB     disk0s5
    
    Code:
    sudo fdisk /dev/rdisk0
    
    Disk: /dev/rdisk0	geometry: 30401/255/63 [488397168 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
     2: AF 1023 254  63 - 1023 254  63 [    409640 -  331213200] HFS+        
     3: 0B 1023 254  63 - 1023 254  63 [ 331886592 -  107419648] Win95 FAT-32
     4: 0B 1023 254  63 - 1023 254  63 [ 439308288 -   39059456] Win95 FAT-32
    
    Anyone know what I need to do to make my partitions boot? I've run out of ideas.

    Any help would be more than greatly appreciated!
     
  2. chriswcs thread starter macrumors newbie

    Joined:
    Jul 13, 2011
    #2
    Someone from another forum suggested I rewrite the MBR using Terminal after booting from my OS X DVD,
    Code:
    fdisk -u /dev/rdisk0
    but that didn't work. Anyone have other ideas?
     

Share This Page