Trouble Adding Perl Modules in Tiger

Discussion in 'macOS' started by Makosuke, May 2, 2005.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Mmkay, perhaps someone can help me with this one.

    There's a Perl module I've used for a web site of mine for a while, called WebMake (HTML::WebMake). It is dependent on a few other modules (Text::EtText, Image::Size, HTML::parser, and IO::String). Under Jaguar and Panther, I had no trouble installing any of these--I could even use CPAN to automate the process.

    Problem: Almost every module I try to build under 10.4 coughs up a huge mess of make errors and won't work. Text::EtText seems to install, but any version of HTML::parser after the ANCIENT 2.25 won't work (though CPAN says they've been tested good in pre-8 versions of Darwin with the same Perl version as Tiger), and HTML::WebMake 2.3 is almost as bad. Most of the erors are along the lines of "incompatible implicit declaration of built-in function", though I don't know what that means.

    I've tried both using CPAN and downloading the modules directly then doing the standard:
    sudo perl Makefile.PL
    sudo make
    sudo make test
    ...which then produces a mess of errors, so proceeding to
    sudo make install a no-go.

    I'm far from a Perl expert, but perhaps somebody else has gotten this working, or maybe can offer some suggestions?

    For reference, I'm running off a completely clean Tiger install (just imported the users using the post-install update thingy), and I have installed the basic Dev Tools (sans manuals and environments I don't use).

  2. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Hmm... small bit of progress. Thinking that perhaps this module uses some C code that the current version of GCC isn't happy with, I tried doing a "gcc_select" to switch between 3.3 and 4.0, and though the errors change under 3.3 (most are "dereferencing pointer to incomplete type" and "storage size of XXX isn't known"), it still fails.

    That's two late nights of work down the toilet on this silly thing.

Share This Page