Trouble booting from USB Snow Leopard drive

Discussion in 'macOS' started by extremelychewy, Aug 13, 2010.

  1. extremelychewy macrumors newbie

    Joined:
    Aug 13, 2010
    #1
    Hi guys, here is what I am working on. I have a macbook pro running Leopard (10.5.8). I am updating to a legitimate copy of Snow Leopard. I'm not installing from the discs, though. I made my flash drive a bootable disk, and I'm trying to install from the USB drive. I'm pretty confident that I did it correctly, but I am still having trouble.

    This is a brand new 8 gb flash drive. Using Disk Utility, I changed the drive to GUID Partition Table and formatted it to Mac OS Extended (Journaled). Then I restored my Snow Leopard .dmg to the flash drive. Everything seems to be going smoothly at this point. I clicked on "Install Mac OS X" in the newly created bootable drive, and after going through the next few windows it started installing. The progress bar increased to about 7%, which took probably five minutes. After this, it stated something along the lines of "installation will continue after reboot," and then rebooted itself. When OS X started back up, it was like nothing had happened. No changes, no continuing installation, it was like the installation hadn't begun at all. I tried a second time and the same thing happened: partial install, reboot, then nothing but regular startup. The USB Snow Leopard Install Drive does show up in the list of bootable drives in the "Startup Disk" portion of System Preferences. Even when I select it as the startup disk and restart, OS X just boots normally almost like it's ignoring my direction to boot from the Snow Leopard install drive. When I hold "alt" during startup to select the drive to boot from, only the regular Macintosh HD is presented as an option. I don't understand why it would show up in System Preferences>Startup Disk, but not show up when pressing alt at startup. I noticed in Disk Utility that the "Owners Enabled" option was set to "No," so I used Terminal to change that to "Yes," even though I'm not sure it makes a difference at all. I named the USB Drive "Snow" and entered the line 'sudo /usr/sbin/vsdbutil -a /Volumes/Snow' in Terminal to do change owners enabled to yes.

    So this is where I am stuck. From what I can tell, I think I created the bootable usb drive properly, but I can't seem to boot from it and running the install off of the drive while already logged into OS X halts at about 7% and reboots.

    Any advice would be greatly appreciated. I'm just stumped at this point.

    Thanks for your help.
     
  2. FourCandles macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #2
    Can I ask why you're trying to install from the USB rather than the DVD?
     
  3. extremelychewy thread starter macrumors newbie

    Joined:
    Aug 13, 2010
    #3
    My DVD drive is having trouble. I have a small dent in the frame outside of the drive. I don't recall dropping it to cause that, but ever since the drive hasn't worked right.

    As far as the USB issue, I have a couple more pieces of information. After attempting the install, where it reboots mid-install, but never resumes installing, a locked boot.efi file appears on the USB drive. If I'm understanding the boot process of the mac properly, shouldn't this be the file that allows the drive to be recognized as bootable? I thought EFI was the equivalent of a pc bios or something...

    Anyway, another thing that I am noticing is that the small green "activity" led on the USB drive (the one that lights up every time it is accessed) does not light up during the booting process or the optional boot screen. Is it possible that the computer just isn't even powering the USB ports during bootup so it isn't recognizing the drive is even there?
     
  4. extremelychewy thread starter macrumors newbie

    Joined:
    Aug 13, 2010
    #4
    Not that anyone cares, but just for the sake of resolution I figured I would post that I figured out the problem. There is something about the physical flash drive itself that causes the macbook to not recognize its existence during boot up, and only recognizes it once OS X has been loaded. I restored the dmg to an external hard drive, which is powered externally rather than being bus powered. Not sure if the power source has anything to do with it, but the macbook recognized it immediately and installed SL without a hitch.
     

Share This Page