Trouble connecting MBA to public wifi with authentication page

Discussion in 'MacBook Air' started by knmlee, Apr 1, 2010.

  1. knmlee macrumors newbie

    Nov 28, 2008

    I've been having trouble connecting my Macbook Air to public wifi in several airports (Denver, San Diego most recently). I select the SSID and get the signal just fine. When I launch Safari or Firefox, I see a redirect to an authentication page - but it never comes up - it just hangs.

    Using my iPhone and Safari, I can connect just fine. When the iPhone browser gets to the redirect screen, it comes up with a dialog box asking to accept a security certificate.

    On the Macbook, I never get asked about a certificate. I can't find any settings that change this behavior. I am not blocking pop up windows blocked and I am accepting cookies.

    Any ideas on how to resolve this? I see lot's of other Macbooks in the airport browsing away so I know I must be doing something wrong.

    Thanks in advance for any suggestions.
  2. Scottsdale macrumors 601


    Sep 19, 2008
    No ideas other than to reboot and try again. I had this exact same problem when I was traveling two months ago. I believed the browser was the problem because the WiFi signal would be fine but I couldn't get past the acceptance page within either FireFox or Safari. It almost seemed like the page was hanging? I hadn't ever had that problem before. I rebooted and it properly displayed the acceptance page and it worked. Wasn't in Denver, but it was at an airport. I have noticed several airports use the same system for WiFi. I have no clue why one would have to reboot or how that would change anything at all, but it worked.

Share This Page