Trouble connecting to WEP wireless network

Discussion in 'macOS' started by cvzyl, May 13, 2008.

  1. cvzyl macrumors newbie

    Jun 2, 2007
    Langebaan, South Africa
    I am having trouble connecting my Powerbook to a community wireless network. I also use a Windows machine to connect to this network by setting the following under network key settings:
    Authentication: Shared
    Data encryption: Disabled
    Key index: 1

    On the Leopard Powerbook I can see the network. I chose WEP encryption and entered the same password used on the Windows machine. However I am unable to connect. It doesn't complain about the password, only times out on the connection. I cannot find the key index setting on the Leopard network settings.

    What am I doing wrong? As it is a community network I don't have the option of changing the network security settings, I don't have control over it. There must be a way to connect to this network.

    Would appreciate any advice.
  2. Cerebrus' Maw macrumors 6502

    Mar 9, 2008
    Brisbane, Australia
    Has it ever worked?
    What kind of WEP is it? Leopard sometimes has problems joining 40-bit encyption Networks.
    When you type in the password, does it say time out immediatly? Or do you manage to log on, and then get timed out?
    Do any other users use Macs/Leopard? Are they having problems?

    This step has worked for me a few times for wireless problems.
    -Goto MacHD/Library/Preferences/ and there should be a folder called System Configuration, with about 7-8 .plist files. Drag any .plist that has to do with networks to the desktop. (If you want you can drag the whole folder, is just has some bluetooth and sleep settings).

    Reboot, and try joining the network again.
  3. asaini0603 macrumors newbie

    May 13, 2008
    Airport Password NonAdmin

    I have a iMac which isnt Intel. I just got a new computer for work, but the IT guy doesn't remember the password,:mad: and told me to get it off of my iMac. I know how to do this if I am logging in as an admin, but how do you do this if you are not?
  4. cvzyl thread starter macrumors newbie

    Jun 2, 2007
    Langebaan, South Africa
    Cerebrus, I have never successfully connected to the network using the Powerbook, only using a Windows machine. It immediately times out, doesn't connect to the network at all.

    I am just a bit confused, it seems that Leopard does not support the shared key authentication method for WEP networks or maybe I'm doing something wrong.

  5. slschwartz macrumors newbie

    May 19, 2008
    trouble connecting to wireless network

    I am having the same problem. I am visiting in Italy, tried to log on to the wireless - which is Belkin - and either get timed out or it seems to connect but I can't do anything ...

    what can I try?
  6. sOwL macrumors 6502


    Sep 25, 2007
    Nerd Cave

    I had exactly the same issue. Just type the "$" symbol in front of the key in the password prompt and it should work fine :)

    EDIT: that "$" thingie is only needed for WEP connections, since WPA will work fine.. i dont know why its needed, but it worked fine
  7. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
  8. lynde macrumors newbie

    Sep 4, 2008
    having the same problem, only in Germany

    I am having the same problem, but in Germany.

    We have been trying to get internet for quite some time, and only now do we have it. The problem is, is that my Mac will not connect to it. In the menu bar it shows that I am fully connected to the internet using our wireless network, but then when I try to use the internet, it says that I am not connected to the internet.

    I have been on the phone with the company all night long, and they say I need a WEP password (or something of the sorts), however when I finally figured out how to enter a WEP password, it says one of three things: 1. the the password is invalid. 2. the connection has timed out. 3. or it says nothing and pretends like I am connected to the internet.

    I am not sure which WEP I need (as there are about a gazillion options-sorry for the dramatization)

    My flatmate says I do not need a password, but I don't trust him. However, when I try to connect to the internet it does not prompt me for a password. It is only when I choose to join other network and click the security to one of the "gazillion" WEP listings. Plus, what number do I insert? The number on the wireless box?

    Any help you could give me ASAP would be greatly appreciated. Luckily, my flatmate's PC connects to the internet, but I would rather use my Mac :) So there you have my problem, my flatmate's computer connects, but my Mac does not and I am in another country. If your responses could be as detailed as possible, since I am not very computer saavy, that would be amazing!

    Thank you in advance!

    P.S. I have a MacBook OS X 10.5.2
  9. frescova macrumors newbie

    Nov 21, 2009
    same issue, and whenever I put in the "$" I can't input more than 2 additional charachters in the password prompt.

    I'mon OSX 10.6.2
  10. professorjay macrumors member

    May 13, 2007
    I had the exact same problem and struggled w/ it for awhile. I gave it one more try and it finally worked when I changed authentication from shared to open.

    I still can't get mine to work w/ WPA though, my preferred choice.
  11. gothamgal macrumors newbie


    Jul 1, 2007
    Leopard 10.5.8 and WEP password troubles

    I've got a similar problem. I have a WEP-encrypted WiFi household network that has worked just fine with our 3 other macs (on a number of different OS ranging from X 10.3 to 10.4.11). I just added a Mac mini running Leopard 10.5.8 and can't get on.

    I've added the Airport MAC ID to the router filtering and can log onto the network. I don't broadcast the SSID but when I enter it and the password it shows I'm connected to the network with full bars.

    However, whenever I open a web browser (Safari or Firefox) I am NOT connected to the internet (can't find server). I check the Airport settings and it's switched me away from auto DHCP to manual and created some random 169 ISP which doesn't point anywhere. Is this a bug?

    I know my network is fine because I'm on with all the other computers. And I know the mini is fine because I can log onto the internet using my neighbor's open WiFi account. I just can't seem to get the mini, once connected to my WiFi account, to remain on it and get through to the internet.

    I've tried trashing preferences and (as someone somewhere else online suggested) changing the router framing and threshold max to 2306.

    I'd appreciate any suggestions. And it would be nice to know if this is a Leopard bug, then has it been resolved in Snow Leopard?

  12. UnixNut macrumors newbie

    Jan 3, 2010

Share This Page