Trouble Connecting to WiFi after Internet Sharing

Discussion in 'MacBook Pro' started by Demondestructor, Apr 5, 2012.

  1. Demondestructor, Apr 5, 2012
    Last edited: Apr 5, 2012

    Demondestructor macrumors newbie

    Joined:
    Apr 5, 2012
    #1
    Hey guys I'm having a problem with my MacBook Pro late 2011 running Lion. Whenever I bring my computer to school, I get my Internet via Ethernet cable connection. With this I turn on Internet Sharing so that I could get Wifi on my iPhone. However, when I return home to use my computer, it won't find any WiFi because Internet Sharing is stuck on and I have tried to turn it off and it won't work. I've also tried to go to the top and click WiFi Off, and then turn it back on but still no luck. The only thing I've found to work is restarting my computer, and logging off simply doesn't do the trick! Any help would be appreciated!!

    This is what it looks like:
     

    Attached Files:

  2. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #2
    What do you see when you click the advanced tab?
     
  3. jwoair23 macrumors newbie

    Joined:
    Feb 12, 2012
    #3
    I have literally the exact same scenario and issue, its incredibly annoying! If I can remember to turn off Internet sharing before closing the lid and my macbook and going home, it works, but if you put the macbook to sleep while internet sharing is still on, the only fix is to restart like you said.

    I would love to find a solution to this.
     
  4. unr1 macrumors regular

    Joined:
    Jul 10, 2008
    #4
    my friend described this same issue to me today.
    any of you guys figure out a fix?
     
  5. tonydallas697 macrumors newbie

    Joined:
    Apr 14, 2012
    #5
    I am having the same issue. This is so frustrating! I have also found that a restart is the only thing that fixes the problem. At least Mac is relatively quick when doing a restart.
     
  6. Demondestructor thread starter macrumors newbie

    Joined:
    Apr 5, 2012
    #6
    So the reason I haven't replied in a while is because I forgot to keep taking screenshots of what the 'Advanced' tabbed looked like (it didn't change anything) like the guy above asked for. However recently I have found that the problem is now fixed, just by unchecking Internet Sharing. Apple must've had a system update or something. I will let you guys know if the problem arises again, but for now it's fixed.
     
  7. stan.nikola macrumors newbie

    Joined:
    Jun 13, 2012
    #7
    I have had this same ANNOYING problem, but one thing I found to be faster than restarting is to plug in ethernet, go to internet sharing options> Wifi Options and clear all wifi settings, then try to turn sharing on then off, and voila my wifi was released...
     

Share This Page