trouble connecting to wifi/ IP address problem. HELP!

Discussion in 'MacBook Pro' started by xpaulinax, Apr 13, 2014.

  1. xpaulinax macrumors member

    Joined:
    Sep 10, 2013
    #1
    So basically I live in an apartment which already has WiFi.

    I've encountered this problem on a few occasions and can usually troubleshoot, but not today!

    The problem is sometimes when I try to connect to WiFi I get an error message which says "can't connect to WiFi because another device on this network is using your computers IP address. Try again later or change your IP address"....something like that.

    So what I do is I go to network preferences>advanced>TCP/IP> using DHCP w manual address

    So i change the address but then it won't connect to router so then I'll change back to using DHCP and renew lease.

    But this isn't working anymore. I've tried every combination of things and have restarted multiple times but still can't connect to internet BC some ******* has my IP address. So how can I fix this?

    Please help. Idk what to do and I have no internet and am using my phone.

    Thanks
     
  2. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #2
    Do you have access to the router? Sounds like it's not assigning u an ip, which means the dhcp is off. Access the router n turn it on?
     
  3. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #3
    Idk how to work the router. First of all I can't reach it BC its on the ceiling of my bedroom closet. And idk if I can actually turn it off or if my apartment people have to do it.

    ----------

    That's pretty much the problem though BC if I set it to "using DHCP" and then hit apply it tells me I have no IP address
     
  4. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #4
    If it belongs to your apartment's people, then talk to them. They may have assigned your ip to someone else by accident. They shld be able to assign you a new one and solve this once n for all.
     
  5. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #5
    I wonder if there's anything else I can do besides turning off the router to fix it though
     
  6. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #6
    Is there a way to request a new DHCP address from my computer? I feel like I shouldn't be having this problem
     
  7. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #7
    More importantly, how can I not have this problem again?
    How can I automatically be assigned an IP address and not have to worry about it?
     
  8. glenthompson macrumors 68000

    glenthompson

    Joined:
    Apr 27, 2011
    Location:
    Virginia
    #8
    The problem likely occurs because you left with your MBP and your lease expired. Someone else then was assigned it. When you returned your MBP attempted to use the last address assigned and got the conflict. Usually, renewing your dhcp address will fix the error.

    Getting a fixed or reserved address requires the router admin to set it up.
     
  9. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #9
    Renewing dhcp does not work.
    When I do that it says "no IP address assigned"

    I just came over to a friends place and I'm still having the same problem

    So its something w my computer

    ----------

    I changed my IP address and it says I'm connected but I get the ! At the top that shows WiFi signal. Says no internet connection. But when I change from manual address to using dhcp it says no IP address assigned

    ----------

    Actually a correction, when I hit "using DHCP" it will assign me an address but I still have no internet connection so it doesn't really work

    ----------

    Well it says I'm connected but no webpages will load
     
  10. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #10
    Clear out all the settings. You seem to have manual configuration on, and the only thing affecting you now should be a misconfigured DNS setting.
     
  11. xpaulinax thread starter macrumors member

    Joined:
    Sep 10, 2013
    #11
    well, i think i fixed it.

    in network preferences, at the top pull down menu i went to edit locations, and made a new location. then i renewed the DHCP lease and now i have internet access. yay.

    thanks for the responses:)
     
  12. Red Fuji macrumors member

    Red Fuji

    Joined:
    Mar 13, 2012
    Location:
    USA-Pacifc Standard Time
    #12
    I know this post is old but I am going to post the fix for anyone who comes across this while looking for a fix to this wi if connectivity problem.
    Youtube can explain it better; but I will post anyway.

    1. While phone is on heat it up with a blow dryer until the screen says TEMPERATURE then turn it off and let it cool down then turn it on. THIS IS A SURE FIX for wi if connectivity issues -
    1. Greyed out out wi if selection .
    2. No network displayed
    3. Intermittent wi if loss.

    look it up on youtube " how to fix iphone wi fi .
    Logic board hardware issue that apple knows about but won't reveal it.:confused:
     

Share This Page