Trouble Ejecting WD Passport Essential HD

Discussion in 'Mac Basics and Help' started by unepetiteetoile, Jan 11, 2009.

  1. unepetiteetoile macrumors newbie

    Jan 11, 2009
    I just got a Western Digital Passport Essential external hard drive. I connected it to my iBook G4 and had no problems loading files onto it. However, when I tried to eject it, I kept receiving the same error message that it's still in use and cannot be disconnected. I even went into the Disk Utilities and tried to eject it there, but it says basically the same thing.

    All of my applications are closed except for my web browser and Finder. How do I eject the drive properly?

    Thanks for any input or help!
  2. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma
    might be spotlight indexing the drive? try excluding the drive from spotlight.
  3. sickmacdoc macrumors 68020


    Jun 14, 2008
    New Hampshire
    The simplest way to find out what is going on is to download the program called What's Keeping Me? by HAMsoft Engineering which will point out just what is preventing the ejection. You'll probably slap yourself when you see what it is-- I usually do!:eek:

Share This Page