Trouble Getting Calls to Work on Yosemite

Discussion in 'OS X Yosemite (10.10)' started by codeoverride, Oct 25, 2014.

  1. codeoverride macrumors member

    Joined:
    Jun 26, 2008
    #1
    I've been reading how to setup Yosemite to make calls but having trouble getting it to work. When I highlight a phone number, I only get the option to FaceTime. I understand that I have to go to FaceTime preference but my panel looks incomplete. Please see screenshot attached.

    [​IMG]
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    You are missing a checkbox to use your cellular connection for calls - have you also setup iPhone Cellular calls in the FaceTime settings on your iPhone? It will take you through a verification code process to make sure you have access to the iPhone.
     
  3. codeoverride thread starter macrumors member

    Joined:
    Jun 26, 2008
    #3
    I'm using iOS 8 on my iPhone (not 8.1) because it's a 4s.

    I don't see the option in my FaceTime iOS preferences :(
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    4S supports 8.1 (4 doesn't)
     
  5. codeoverride thread starter macrumors member

    Joined:
    Jun 26, 2008
    #5
    Is iOS 8.1 required to make calls from Yosemite? I thought it was just iOS 8. The reason that I haven't upgraded is because I heard that 8.1 does not work very well with the older iPhone 4s.
     
  6. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #6
    No. 8 for calls, 8.1 for SMS

    I was just answering your point about 8 on iPhone 4S' (mine runs fine BTW)
     
  7. codeoverride thread starter macrumors member

    Joined:
    Jun 26, 2008
    #7
    Thanks, I understand but if I have iOS 8 on the iPhone 4s and Yosemite on the desktop, not sure why I'm missing the option you mentioned :confused:
     
  8. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #8
    Me neither. :confused:

    ----------

    Have you setup FaceTime on both MBP and iPhone to use both your mobile number AND an email address, same email address on both?
     
  9. codeoverride thread starter macrumors member

    Joined:
    Jun 26, 2008
  10. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #10
    Then I would un-enable the Appleid for FaceTime on the iPhone, then re-enable it, see if that kicks it into life....?

    At some point the iPhone has to realise you have another device enabled for FaceTime on your Applied, then it will give you the option to enable cellular calls from that device, then step you through the verification process.

    If all else fails, I'd put 8.1 on, you gain the SMS feature (which I use more than Call continuity TBH)....
     
  11. codeoverride thread starter macrumors member

    Joined:
    Jun 26, 2008
    #11
    Thanks for the help. I installed iOS 8.1 and now it works :)
     

Share This Page