Trouble installing 10.10.4

Discussion in 'OS X Yosemite (10.10)' started by Asthmatic Kitty, Jul 1, 2015.

  1. Asthmatic Kitty, Jul 1, 2015
    Last edited: Jul 1, 2015

    Asthmatic Kitty macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #1
    So I started downloading the 10.10.4 update last night on my MacBook, closed the lid and came back to it this morning to find an error message saying something about updates not installed correctly/couldn't be verified.

    But then it took me through the standard steps you go through to install a software update, like inputting your Apple ID password and choosing whether to set up iCloud Keychain etc. It seems I'm still on 10.10.3 though, despite this, after checking in About This Mac.

    Now when I go to the App Store Updates tab it still lists 10.10.4 (when I click Update on the right nothing happens), and the spinning wheel/Checking For updates goes on forever.

    Have tried restarting numerous times, but the same thing happens every time. Have also tried repairing disk permissions to see if that did any good, but nothing doing.

    Any ideas? Thanks for any help.
     
  2. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #2
    Same here on one of my imacs. The app store was pretty much down last night altogether. I really thought we were at a point that this sort of crunch would have been a thing of the past. We'll give it another try in a bit....

    now seems to have finished..
     
  3. Asthmatic Kitty thread starter macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #3
    I think if the Checking for updates spinner would ever stop spinning, I could probably just update again and it would be OK.
    Apple software is so frustrating these days, sigh.
     
  4. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #4
  5. Asthmatic Kitty thread starter macrumors member

    Asthmatic Kitty

    Joined:
    Sep 29, 2014
    #5
    Woke up this morning to have it already downloaded and ready to install - all good now!

    Guess it was just strain on their servers, like you said.

    Thanks for the help, chaps.
     
  6. mikegoldnj macrumors regular

    Joined:
    Apr 27, 2005
    #6
    Went through the update process in App Store...showed that updates had been done but, then still showed updates available and...Photos app disappeared from my machine.

    Activity monitor showed stalled processes for the installers so I ended those and then downloaded the "Combo" installer but when going through that process...It won't let me install. The message says that "the volume does not meet the requirements for this update."

    There is more than enough space on the volume, almost 300 GB, so what is the problem?
     

Share This Page