Trouble Installing Leopard On PowerBook G4

Discussion in 'PowerPC Macs' started by MaxMike, Nov 2, 2010.

  1. MaxMike macrumors 6502

    Dec 6, 2009
    My friend recently got a PowerBook G4 1.67 from eBay. When he tried to put Leopard on it (retail family pack disc) the install would freeze either during the actual install or during the formatting. My friend talked to someone and was told that that logic board was failing and he also kept getting kernel panics. He sent that one back, but today got an addition 1.25 PowerBookG4. Tiger installed fine, but would get kernel panics sometimes (I was using the computer) and it would also randomly freeze up requiring a hard restart. When he got home from school, he tried to install Leopard on it and he kept getting the same problems as the others. Is something small just wrong such as the PMU or PRAM? Or is it something more serious like the logic board in both cases? Thanks for any help!!! :apple:
  2. longwood macrumors regular

    May 10, 2005
    I recently acquired a PowerBook myself and had some issues installing Leopard. I tried from the internal drive and that didn't work. I then tried installing it via Target Disk Mode. The 1st time it didn't work either. After that I reset the PRAM and PMU and the 2nd time formatting the drive and installing Leopard seemed to work. I don't why it didn't work the first couple of times, but I eventually got it.

    Try reseting the PRAM, PMU and maybe installing via Target Disk Mode, if possible.

  3. Yanal macrumors newbie

    Aug 3, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    Do you have enough ram ? You need at least 500mb, boot it from a different machine and see how much ram you got there.

Share This Page