Trouble installing printer driver

Discussion in 'Mac Basics and Help' started by slyskittle, Mar 4, 2011.

  1. slyskittle macrumors newbie

    Joined:
    Feb 26, 2011
    #1
    I'm trying to connect my canon mp560 to my imac (10.5.8) and the connection goes fine (WLAN) but when I go to select the canon driver it's not there even though I installed it.
    When I go to print something I can select the printer, it says "sending to printer" and then "printer ready" but nothing prints.
    Does anyone know what could be wrong?
    I've only just switched to mac so have absolutely no idea
     
  2. dvanvught, Mar 5, 2011
    Last edited: Mar 5, 2011

    dvanvught macrumors newbie

    Joined:
    Mar 5, 2011
    #2
    Canon Imageclass D860

    Hi, I'm new to the forum and was wondering if there are any drivers available for the canon imageclass d860 printer/copier/fax machine. I know it's a long shot but I was told that my HP 1215 color laser printer would not work and found "cups drivers?" for it and managed to install them to get it working. I run a small business and would really appreciate it if someone has any information on getting the canon printer working.

    Thx
    Dave

    Here's the link I got for my HP color laser CP1215
    http://instantaneousinstances.com/2008/12/getting-an-hp-color-laserjet-cp1215-working-on-a-mac/
     
  3. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #3
    Have you read the pdf instructions provided by Canon on their site? They are actually for the mp495 but there are references to the mp560 series. I think you missed a few steps.

    http://www.usa.canon.com/CUSA/assets/app/pdf/wireless/setup_MP495_mac.pdf
     
  4. slyskittle thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #4
    I followed the instructions exactly but when I get to the registering section (p. 16 on the link), where is says "print using" I can't find "canon mp560". I just presumed this was a problem with the drivers but maybe it's something else? It detects the printer no problems and when I check the connection strength it is high but it just won't print when I send things to it. I've just connected it to my PC (on the same network) and it prints perfectly with that.
     
  5. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #5
    Two things to try.

    Remove the printer from the printer list and then re add it.

    Give the app Print Therapy a try. Has different versions for different OSes. Get the correct one for your OS. I'm pretty sure you can use it once without having to pay the shareware fee.

    Print Therapy
     
  6. slyskittle thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #6
    thanks for the help but unfortunately nothing worked, even when I used Print Therapy. I'll just have to keep trying. Thanks again!
     

Share This Page