Trouble migrating from old iMac

Discussion in 'iMac' started by Arhoolie, Jan 9, 2013.

  1. Arhoolie macrumors newbie

    Jan 9, 2013
    Hi folks,

    My new iMac arrived today and I am having a bit of a problem transferring stuff from my previous one.

    The oldster is a 2005 G5 model running 10.4.11 (Leopard I think?)

    I have connected the two machines via ethernet cable, however they are not recognising each other on migration assistant.

    I downloaded the migration and dvd/cd sharing update to my old computer before commencing.

    The problem is that the new computer's migration assistant keeps telling me the other computer needs an update on its migration assistant.

    I have to my knowledge got old Mac as up to date software-wise as it will go.

    I tried starting up pressing t, but it still wasn't recognised by new Mac.

    I don't have a thunderbolt/firewire adapter to try with but doubt that is the problem. All advice seems to say ethernet will do just dandy.

    What am I missing?

    If I can't do a full migration it will be annoying but no great disaster. Not being able to transfer my iTunes stuff will be a major pain though.

    All thoughts greatly received.

  2. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    You probably need 10.5.8 and Migration Update on that OS version to do so.
  3. Fishrrman macrumors G5


    Feb 20, 2009
    I just had a similar problem yesterday.

    I was trying to migrate my user account from my old computer (PowerMac g4, OS 10.4.11) to my brand new Mac Mini (10.8.2).

    I had heard that version 10.8 of Migration Assistant wouldn't work with anything older than OS 10.5. I though I could get around that by cloning the partition that held my (old) OS to a backup drive, then connect that to the Mini, then migrate. Didn't work.

    So -- won't work in "target disk mode", and won't even migrate from a separate hard drive.

    My solution:
    My backup drive also had a copy of OS 10.5 that I had been experimenting with (but was not my "main" boot drive, I just preferred 10.4).

    So, I did this:
    1. Booted from the backup drive running OS 10.5
    2. "Migrated" my account from 10.4 (g4 internal drive) to 10.5 (backup drive)
    3. Disconnected backup drive from g4 and took it to the Mini
    4. Using Migration Assistant on the Mini, migrated my 10.5 account from the backup drive to 10.8.2 on the Mini.

    I had to do the migration TWICE, and it took more time, but it worked.

    You -will- need either an external drive with a bootable copy of 10.5 on it, or, you might be able to first update your existing Mac to 10.5, and then connect it via firewire target disk mode, or by ethernet. Hmm... the new iMacs dropped the firewire port (unless you have the Thunderbolt-to-firewire adapter), so, is migration via ethernet possible?

    Hope this helps!
  4. Arhoolie thread starter macrumors newbie

    Jan 9, 2013
    Tell me if I have this right? Mountain Lion is not going to migrate anything older than 10.5?

    Old Mac is a PowerPC and not an INtel so as far as I know I cannot upgrade it to 10.5.

    So I'd need to get another drive and buy 10.5 to run on it and carry out two migrations?

    Thats rubbish (not your advice but the situation):mad:
  5. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    10.5 works on PowerPC based Macs. As for needing an external drive, I'm not sure it's necessary - it's just how the person did it. I think if you upgraded your system to 10.5.x it would work like you want it to.
  6. Arhoolie thread starter macrumors newbie

    Jan 9, 2013
    Now having trouble mounting Leopard.

    Thanks all.

    An update with a new problem!

    I got an external drive and backed up everything from Old Mac on it. I then found a copy of Leopard start-up disc to borrow from a friend to upgrade OLd Mac so New Mac's migration assistant would accept it.

    When I put this in Old Mac's drive it takes a few goes to get it to mount. Much whirring and clicking and grinding. On the occasions it does mount and I try to install it restarts the computer and always spits out the disc during restart, before the install can proceed.

    The disc is clean and undamaged. I presume its just because the drive is on its last legs really.

    Anyone any thoughts on how I might get Old Mac to accept the upgrade disc?

    Could I plug the external drive with my Old Mac back up on it into my New Mac, along with the Leopard start-up disc, and do anything clever with it?

    BTW, my new superdrive does not work on the old Mac and I have no other dvd drives I can use to get the install onto Old Mac.
  7. comatory macrumors 6502a


    Apr 10, 2012
    Sucks for you but honestly, we are talking about 8 year old OS so its bound to be a bit hard.
    The easiest would be to borrow external USB DVD drive from someone and install update from that, or use a PCwith DVD drive, create iso image - you can then mount the image file on your old mac for upgrade.

    You might also try this: use time machine to create a backup to external hard drive - then use the Migration Assistant and see if it picks up the backup. My hunch is it will probably be the same problem, ie 10.4 backup wont be recognized.

    I know its not ethical but man the easiest thing you can do is to grab off Leopard from torrent site and just mount the image to install the upgrade.
  8. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    I am not 100% sure this works but you can put the disk in the imac or in the superdrive and share it over the ethernet, then boot the old mac by holding down the Option key, and see if the CD/DVD shows up as a networked CD/DVD, if so you can then proceed but it will be slow.

    Edit: Or it might be possible to install from the iMac on the external drive, but then you need to select Apple Partition Map for it to work, GUID will NOT work.
  9. Arhoolie thread starter macrumors newbie

    Jan 9, 2013
    Yet again one problem falls and another rises.

    In the end I got lucky and the old iMac accepted the Leopard disc and installed it. I then went to software update and took it to the most recent version.

    However, now when I start-up I get two finder windows appearing - one with my home file outlined and the other with "downloads at the top of the pane, but nothing outlined in the menu. The downloads window has its close, reduce and expand lights at the top left lit up, the other window does not.

    Neither window will respond to the mouse in any shape of form, other than moving around the desktop.

    When I open force quit it shows finder "not responding". I relaunch and the same two windows come back every time.

    Thanks for your continuing attention!
  10. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Repair permissions on the disk in Disk Utilities, if this does not work you could try to redo the update, you manually have to download 10.5.8 from Apple's web site and Install, many times this will resolve problems

Share This Page