Trouble mounting boot camp Vista partition in OS X

Discussion in 'Windows, Linux & Others on the Mac' started by torrence, May 11, 2008.

  1. torrence macrumors newbie

    Joined:
    May 11, 2008
    #1
    Hi,

    I am experiencing some trouble accessing my Vista partition from OS X.

    I have a 250GB disk set up with two partitions through the Boot Camp
    assistant.

    Diskutil list gives:

    /dev/disk0
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *232.9 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Home 211.9 Gi disk0s2
    3: Microsoft Basic Data 20.7 Gi disk0s3

    1) In Vista partition 3 is shown as a NTFS drive
    2) In OS X it is shown as FAT-32, and I'm not able to mount it,
    or run verify/repair from disk utility.


    Solutions tried:

    1) Installed MacFuse + NTFS-3G
    2) Tried the following in Terminal: sudo ntfs-3g /dev/disk0s3 /mnt/Windows
    3) Tried the command fixmbr from Vista
    4) Installed Paragon NTFS


    Diskutil info disk0s3 gives:


    Device Identifier: disk0s3
    Device Node: /dev/disk0s3
    Part Of Whole: disk0
    Device / Media Name: Untitled

    Volume Name:
    Mount Point:
    File System: MS-DOS FAT32

    Partition Type: Microsoft Basic Data
    Bootable: Is bootable
    Media Type: Generic
    Protocol: SATA
    SMART Status: Verified

    Total Size: 20.7 Gi (22216327168 B) (43391264 512-byte blocks)
    Free Space: 0.0 B (0 B) (0 512-byte blocks)

    Read Only: No
    Ejectable: No
    Whole: No
    Internal: Yes


    diskutil verifyDisk disk0s3 gives:


    Started verify/repair volume (filesystem) on disk disk0s3
    ** /dev/disk0s3
    Invalid BS_jmpBoot in boot block: 464bd1
    Error detected while verifying/repairing volume disk0s3: Filesystem verify or repair failed (-9957)
    [ + 0%..10%..20%..30%..40%..50%..60%..70%..80%..90%..100% ]
    Finished verify/repair volume (filesystem) on disk disk0s3
    Error detected while verifying/repairing volume disk0s3: Filesystem verify or repair failed (-9957)


    Is anyone able to read and write all Windows Vista files on the NTFS partition from OS X?

    The Vista partition was originally created with the Boot Camp Assistent,
    but since the assistent only lets you create FAT-partition, the Windowsinstaller had to reformat the partition to NTFS.
     
  2. sash macrumors 6502a

    sash

    Joined:
    Nov 23, 2004
    #2
    Hi torrence!

    You mean, has anyone been able to install Vista with BC and run it without problems? Then the answer is yes.

    That's like it should be...

    I've had a similar problem with Paragon driver, but there have been nothing wrong with the Windows partition before that, so I could find the cause pretty easy.
     
  3. torrence thread starter macrumors newbie

    Joined:
    May 11, 2008
    #3
    the part about flawlessly was supposed to refer to being able to access a Windows Vista partition from OS X.

    I can boot both my systems fine, but not beeing able to fetch my windows files
    from OS X is a big problem. From Vista i can access my OS X files without any trouble through macDrive
     
  4. italiano40 macrumors 65816

    italiano40

    Joined:
    Oct 7, 2007
    Location:
    NY
    #4
    try using macfuse in Mac OSX and get the NTFS driver to use it in the finder window
     
  5. torrence thread starter macrumors newbie

    Joined:
    May 11, 2008
    #5
    already tried installing macFuse (Part of my, solutions tried list)
     
  6. sash macrumors 6502a

    sash

    Joined:
    Nov 23, 2004
    #6
    Hi torrence,

    Sorry for misunderstanding.

    With Mac OS tools only you should have read access to the NTFS partition. To write on it you have to use either Paragon or macFuse; I believe, these two drivers are the only solution available at the moment. I've got Paragon installed on one machine; while not 100 % perfect, it does allow you to write on the NTFS partition.

    sash
     
  7. torrence thread starter macrumors newbie

    Joined:
    May 11, 2008
    #7
    Hi again,

    and thank you for your replies.

    I am aware of the fact that i would need MacFuse og Paragon to write to my NTFS drive. And have also tried both.

    The main problem remains though, as OS X does not recognize the NTFS drive, and won't even let me read it.

    The partition just sits in Disk Utility as a Unmountable, Unrepairable and Unverifyable Fat-32 drive, even though I'm running Windows Vista on it.
     
  8. Hennesie2000 macrumors 68000

    Joined:
    Sep 29, 2007
    Location:
    Maryland
    #8
    I am having the same problem with a XP partition. It used to work fine when I first ran Boot Camp and installed windows. Then one time windows crashed and now the XP volume will no longer mount in OSX. Mine also shows in disk utility but I can do nothing with it except view the info. I have macFuse installed and used to use it. The OSX partition mounts fine in XP using macdrive and I can read and write all I want. It would be nice however to be able to do the opposite again.
     
  9. rafaelromao macrumors newbie

    Joined:
    May 29, 2008
    #9
    I'm having the same problem since I've installed Leopard, with Tiger I never had such problem, neither with Vista.

    I saw somewhere that this exception is thrown by UNIX systems when the first byte read from the partition is not one of some desired values :confused:, but I don't know if it proceeds. It's really strange that Vista boots without any problems and Leopard seems to have a crashed partition in its hands.

    I thought 10.5.3 would fix it (something like that is listed in the release notes), but yesterday I've installed it and nothing has changed. I'll try to remove Vista and try again, now with 10.5.3 and bootcamp 2. If I have success I'll post a reply.
     

Share This Page