Trouble Opening Certain Installers On Mac Pro

Discussion in 'Mac Pro' started by strausd, Dec 22, 2010.

  1. strausd, Dec 22, 2010
    Last edited: Dec 22, 2010

    strausd macrumors 68030

    Jul 11, 2008
    So recently I tried to install a Genuine Fractals trial on my Mac Pro but the installer would never open. Whenever I tried opening it on my MacBook Pro, the installer opened perfectly. Now I am trying to install a Twixtor demo on my Mac Pro and am encountering the same problem. It opens fine on my MacBook Pro, and I have no idea why it won't open on my Mac Pro. I tried clicking the checkbox under Get Info for opening with Rosetta, but that didn't do anything. Does anyone have any ideas?

    Would it be possible to copy the files that were installed on my MBP to my MP without any issues? And how can I find out where they were installed to?
  2. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
    When you try to open it, what happens? Completely nothing? Take a look at Console when you try to open it, maybe it will give a hint what's wrong. I would try repairing permissions with Disk Utility as well, it's worth a shot.
  3. strausd thread starter macrumors 68030

    Jul 11, 2008
    Oh my gosh thank you so much!

    Here is what would happen, after I double click the installer app on the .dmg, it shows up in the dock, and about a second later a second icon just like it shows up in the dock. Once the second icon shows up a little text box pops up saying "Authenticating installer, please wait." After about 2, maybe 3 seconds it just goes away. I don't even get a message saying it quit unexpectedly.

    Looking at Console it gave me two things:

    12/23/10 2:34:59 AM[3415] 2010-12-23 02:34:59.210 ReportCrash[3415:2e03] Saved crash report for Twixtor5.02Installer[3433] version ??? (???) to /Library/Logs/DiagnosticReports/Twixtor5.02Installer_2010-12-23-023459_localhost.crash

    12/23/10 2:35:01 AM Finder[3013] Error loading /Volumes/CB 2TB 1/strausd/Library/Components/Grammarian.component/Contents/MacOS/Grammarian: dlopen(/Volumes/CB 2TB 1/strausd/Library/Components/Grammarian.component/Contents/MacOS/Grammarian, 262): no suitable image found. Did find:
    /Volumes/CB 2TB 1/strausd/Library/Components/Grammarian.component/Contents/MacOS/Grammarian: no matching architecture in universal wrapper

    Everytime I tried to open the installer it gave me that. I use this app called Grammarian for helping correct grammer in a variety of different applications. All I did was quit that and it opened perfectly. You are a life saver!

Share This Page