Trouble printing in Lion to a network Dell 2330dn Laser

Discussion in 'Mac OS X Lion (10.7)' started by btracy713, Jul 9, 2011.

  1. btracy713 macrumors newbie

    Joined:
    Apr 19, 2011
    Location:
    Delaware
    #1
    Hello all,
    My Dell 2330dn Laser printer which I have on the network was working just fine with Snow Leopard, now that I upgraded to the GM version of Lion, when I try to print to it on my machines running Lion, it comes back and says "Print file was not accepted" no matter what I try to print, yet my other machines not running Lion still print to it just fine. I tried removing the printer and putting it back on; no such luck..... Any ideas?......
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Wait for Lion-compatible drivers :rolleyes:
     
  3. NJRonbo macrumors 68000

    Joined:
    Jan 10, 2007
    #3
    You are not alone. I cannot print with my Konica printer, either.

    Seems to be quite a few issues with Lion and some printers.
     
  4. kLy macrumors newbie

    Joined:
    Mar 9, 2007
    #4
    Try re-add your printer as a LPD printer instead of IPP. I had the same issue too and this worked for me on a Lexmark :)
     
  5. Sumleilmus macrumors member

    Sumleilmus

    Joined:
    Nov 6, 2011
    Location:
    /
    #5
    Yes! LPD!

    Thank you for this. Minor network changes at work made 2 formerly functional Lexmark printers no longer able to print from my Lion MBP, with error message as detailed above. I have all the latest drivers Apple has on offer.

    Two IT pros and I could not get printing back by reboot, deleting and recreating IP Print printer profiles, &c., until I:

    1. Found this and other post
    2. Turned off firewall in MBP
    3. Removed and recreated printer profiles as IP Print>LPD
    4. Turned firewall back on

    Now documents print when sent from MBP to either printer.
     
  6. MacElvis macrumors newbie

    Joined:
    Jan 19, 2012
    #6
    Lexmark printing with OS X 10.7.2

    after several (and a DO MEAN a BUNCH of tries and 10+ hours of various sittings), i have found a process to enable printing from an Apple MBA running Lion OS X 10.7.2 to a Lexmark 7675 all-in-1 printer.

    this process does NOT use Bonjour or MAC IP print addition process... which had limitations and various issues.

    you need 3 downloads

    A) Lexmark 7600 Series Web Installer for MAC OS 10.6 from http://downloads.lexmark.com/downloads/cpd/ 7600 Series Web Installer.dmg
    (not a typo... it is 10.6 as there is no 10.7 version installer and it is under the heading of PRINTER DRIVER FOR MAC OS X 10.6)

    B) Lexmark Wireless Setup Assistant application for Mac OS X 10.7 ... from Lexmark Website http://support.lexmark.com ... make sure this is for version 10.7

    C) Lexmark Printer driver for Mac OS X 10.7 ... from Lexmark Website http://support.lexmark.com ... make sure this is for version 10.7

    the sequence that worked for me was to run C), B) and A)... because i couldn't find A) for OS X 10.7. The process may work in any sequence.

    using this process, I have USB and Wireless connection for printing... as well as wireless scanning!

    I posted this to say "thanks" for the various clues in this thread to get my connection to work... Apple support and Lexmark support were pretty much useless to trouble shoot this one.

    hope this helps others!
     
  7. ashchurch macrumors newbie

    Joined:
    Nov 5, 2012
    #7
    LPD worked for me too

    ...but I went about it a bit differently. Mountain Lion saw and installed my Dell 2330dn straightforwardly. When I printed, I saw no error messages - but I didn't see anything come out of the printer either. If the same happens to you, try going to Settings, click Show Printer Webpage and note down the IP address. Then under System Preferences, go back to Print & Scan, remove the printer, choose Add Printer or Scanner... select IP and add the address you noted down under Address, choose Line Printer Daemon - LPD under Protocol and then click Add. Hopefully that should do the trick.
     

Share This Page