Trouble printing through Time Capsule

Discussion in 'Mac Accessories' started by Thorbjorn, Apr 6, 2008.

  1. Thorbjorn macrumors regular

    Joined:
    Jan 14, 2008
    #1
    I got and set up a new iMac 24 and it's playing well with Time Capsule. Easy initial transfer, easy backups. The one issue I'm having is with trying to print through it to a Canon Pixma iP3000. Yeah, the printer's a little old but I downloaded and installed its updated driver and it seems to be recognized all around: can print with a direct USB hookup to the iMac, and it shows when I click + to add a printer in the System Prefs. After I click "+", it scans and brings up another box that reads as follows:
    Name: Canon iP3000​
    Location: BTC Time Capsule​
    Print using: Canon IJ Printer​
    All of which is correct, and the printer shows up as a Bonjour connection. (Don't know whether I'm expressing that right.)
    Problem comes when I confirm and click Add. Basically nothing happens for a while and then I get an error message as follows:
    An error occurred while trying to add the selected printer. Error: -9672.​

    Any thoughts anyone? I mean, I can just go back to hooking the printer up directly to my main computer, but I'm hoping to figure this out so I can wifi printing from my laptop etc. All help welcome. (I've done a bunch of searches and haven't come up with solution yet...) :confused:
     
  2. LimeyYankee macrumors newbie

    Joined:
    Jul 2, 2007
    #2
    I had the same problem as you after setting up a Time Capsule. Under Airport Utility if said that my printer (Canon MP 610) was working ok. However I couldn't get it to print wirelessly.

    I did a bit of looking around on the internet and this is what helped me out.

    I had to unplug my usb cord to the Time Capsule, then turn the printer off. Go into Printers & Fax under Sys Preferences. Delete your printer, then plug your printer back into the Time Capsule and turn the printer on. Now click the + button and add your printer back on and us the IJ printer driver.

    After I did this my printer worked wirelessly as advertised, I hope this might work for you :)
     
  3. Pkaa macrumors newbie

    Joined:
    Jan 31, 2011
    #3
    Very helpful

    Thank you very much.

    I just bought an HP P1102 and struggled to get it to print wirelessly with my TC and after this easy setup it works. Thanks - if only I had found your posting prior to trying out many other options

     
  4. czzchen macrumors newbie

    Joined:
    Mar 24, 2011
    #4
    still not working

    I just follow your way unplug/turning off/delete/plue/on/add.... and still not working

    my printer is Canon LBP5050
    Time Capsule
    and one PC, two MacAir

    any suggestions will be very appreciated

    cheers
     
  5. SCoetzee macrumors newbie

    Joined:
    Jun 28, 2011
    #5
    Thanks

    Thx this worked for me!!
     

Share This Page