Trouble restoring iPhone 6 plus to my X

Discussion in 'iPhone' started by Lifesuxsbad, Nov 3, 2017.

  1. Lifesuxsbad macrumors regular

    Lifesuxsbad

    Joined:
    Jun 15, 2010
    #1
    Ok I havent't received my iPhone X yet (i'm in the nov 17-24th bracket) but my daughter got hers today and she is having problems restoring from a previous backup. She has the iPhone 6 plus and is trying to restore from her backup onto her iPhone X. She gets the following message..
    "iTunes could not restore the iPhone "iPhone" because the backup was corrupt or not compatible with the iPhone that is being restored."

    I know its compatible so I am assuming its a corrupt file in the backup (she has had this iPhone for a long time so very possible something is corrupt) ...any easy way of figuring out what file it is? Should we just delete her backup and then just try and back it up again? I have not seen the phone yet but she called to tell me she was having this problem. Any suggestions?
     
  2. Zwhaler macrumors 604

    Zwhaler

    Joined:
    Jun 10, 2006
    #2
    What version of iOS was her iPhone 6 running when the backup was taken?
     
  3. StoneCold X macrumors regular

    Joined:
    Apr 22, 2015
    #3
    Update iTunes.

    I had a similar situation about a month ago and it was because I wasn’t on the latest version of iTunes
     
  4. geoffm33 macrumors 6502

    geoffm33

    Joined:
    Dec 27, 2010
    #4
    I had the same issue. I upgrade iOS on the X and then the restore through iTunes worked.

    The iOS on my iPhone 7 was newer than the X so that was the issue.
     
  5. steffi macrumors 6502a

    Joined:
    Jun 7, 2003
    #5
    Meaning what though? You had upgrade iOS on X before you could restore backup?

    I'm in the same boat.

     
  6. Lifesuxsbad thread starter macrumors regular

    Lifesuxsbad

    Joined:
    Jun 15, 2010
    #6
    She is not at home of course so as soon as I talk to her I will get back to y'all.
     
  7. gpoop macrumors regular

    Joined:
    Sep 8, 2017
    #7
    Could this be the reason why the following is happening to me cause last night I tried twice to update Itunes and got an error so I didn't bother with it. Now I'm dealing with this.

    Restored my phone from latest backup, watched it go threw all my songs one by one now seems to be stuck in step 4 saying "waiting for items to copy. It's been like this for almost an hour now.

    Could it be that it's just not done or it's a glitch and I should hit done?
     
  8. yang88she macrumors regular

    Joined:
    Oct 26, 2011
    Location:
    ATL
    #8
    same issue as well, tried setting up as a new phone, tired the whole camera to the old phone, still no luck. I deleted my old back up, backing up my old phone again, and trying to see if I can restore from the latest back up
     
  9. CaptMarvel macrumors 65816

    CaptMarvel

    Joined:
    Sep 20, 2014
    Location:
    North Carolina
    #9
    Update iTunes. Make sure iPhone 6 Plus is on 11.1 then back up in iTunes. Setup iPhone X as new phone, then update it to 11.1 as well. Then restore the iPhone X using the backup created from the iPhone 6 Plus.
     

Share This Page

8 November 3, 2017