Trouble Restoring Jailbroken iPhone to Its Former Glory

Discussion in 'Jailbreaks and iOS Hacks' started by avsrock90, Aug 14, 2010.

  1. avsrock90 macrumors newbie

    Joined:
    Feb 5, 2010
    #1
    Hi guys,

    I purchased an unlocked iphone 3GS running 4.0 from craigslist about two months ago. I am led to believe it was jailbroken using pwnagetool and I am 99.99% sure it has the old bootrom.

    I used it in Europe successfully with many different carriers, so I know the unlock worked. I came back to the US yesterday, downloaded some Cydia apps, and plugged it into my computer. It synced with iTunes then came up with an error saying that it was running out of space. So I tried adjusting sync settings to put less stuff on it, but iTunes was freezing up (I'm running a mac, btw).

    So I unplugged the iPhone mid sync, and the iPhone itself gives me a message telling me to clear data off. I try to delete videos from inside of the iPod app, but it won't load any of my library. I plug it back into the computer and iTunes says that it cannot read the data on the phone so that I need to restore. Crap. But no big deal, I think, I'll just restore it and rejailbreak it.

    So I restore it to iOS4.0 via iTunes and then have pwnagetool create a custom ipsw for me, but when I throw the phone into recovery mode and try to restore to this custom ipsw, iTunes says that the iphone cannot be updated because of an unknown error. I've tried it a couple of times and it won't work and I'm not sure why. Anyone have any thoughts? I am still able to restore to 4.0 from recovery mode.

    I've heard about the ease of jailbreakme, and I was thinking of upgrading to 4.0.1 by holding option and clicking restore in iTunes and then jailbreaking that way (I think you can move "forward" using "restore," right?). Even if this worked in theory, the problem here is that I don't have AT&T so I can't activate through iTunes in order to get safari working on the phone to load jailbreakme.com.

    Anyone have thoughts? I thought I had the whole process figured out, but it looks like I was wrong….Thanks for any help.
     
  2. Mademan12321 macrumors 6502

    Joined:
    Jun 29, 2009
    #2
    If your SHSH is backed up (check with tiny umbrella) you can do a total restore as new using the 4.0.2 update then downgrade using the 4.0 update and possibly 4.0.1 update if he backed that one up too.
     
  3. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #3
    Once you update to official firmware, your phone is no longer pwned which means you can't install custom firmware anymore and the reason you are getting that error after trying a firmware created by pwnagetool.

    Options:
    1) More easy. Get ATT sim card somehow, friends, eBay, or etc., so you can activate, use safari go to jailbreakme.com on firmware 4.0 / 4.0.1. Afterward, install ultrasnow through Cydia to unlock.

    2) Do you SHSH 3.12 or below SHSH saved? If you aren't sure, use tinyumbrella to find out. If you do, google instructions on how to downgrade to 3.12 or below using your saved SHSH. Afterward, you can JB using Pwnagetool or Redsnow.
     
  4. avsrock90 thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #4
    Ah yes, I had forgotten that you couldn't do the pwnagetool jailbreak on 4.0 unless it was previously jailbroken....Thanks for the reminder.

    I know that I have SHSH's on sydia for 4.0,4.0.1, and something in the 3 series. "Apple" (really Saurik's server) refused the flash to 3.1.2, so hopefully it's 3.1.3. Then I can redsnow it, and flash the custom ipsw for os4.

    If I have to get an AT&T sim and do it that way, do I need an AT&T contract, or can it be PAYG?
     
  5. avsrock90 thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #5
    Got the 3.1.2 to go through to the point where it says that it cannot be restored because of 1015 error, but I am told this is normal. However, redsnow doesn't work... it hangs on "installing activation bundles." Pwnagetool asks me to plug the phone into USB but doesn't recognize it, then its custom firmware (3.1.2) fails to restore in iTunes....

    I'll give it another whirl in the morning, but looks like jailbreakme is becoming the best option. :confused:
     
  6. avsrock90 thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #6
    Umbrella doesn't give me any info, but I was able to go back to 3.1.2 and 3.1.3, so I believe that is proof positive that my SHSH's are backed up? I know that Cydia told me it had SHSH's for 4.0 and 4.0.1. Is that the only potential risk in going forward to 4.0.2?
     
  7. macattack87 macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #7
    you can follow these steps:

    1. Buy "phonebook sim" (link at bottom)
    2. point your itunes host files to cydia's servers instead of apple
    3. restore to 4.0 (use a normal copy of 4.0) using your SHSH blobs
    4. itunes will activate the phone on its on as if you had an AT&T card in
    5. turn on wi-fi, go to jailbreakme.com and jailbreak
    6. take the phonebook sim out and put your real sim in
    7. go to cydia and run ultrasn0w to unlock your phone

    everything should be running now, you should have a jailbroken/unlocked 3GS on IOS4.0

    here is the link:
    http://www.crispytech.com/2010/07/18/activate-iphone-4-3gs-without-sim-card/
     
  8. avsrock90 thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #8
    Alright, I finally got it working. Went back to 3.1.2, had to redo my hosts file because I copy/pasted wrong the first time. Had to do redsnow twice, on the first time not installing cydia, on the second time actually installing cydia in order for it to work. Then flashed to a pwnagetooled 4.0 firmware. iHazSuccess.
     

Share This Page