Trouble Saving Hosts File

Discussion in 'Mac Basics and Help' started by Modified!, Oct 17, 2009.

  1. Modified! macrumors newbie

    Joined:
    Oct 17, 2009
    #1
    Hello MacRumors,

    I'm having problems with editing my "hosts" file in the /private/etc/ folder on my Macbook Pro. After I am done editing it with TextEdit, it fails to save the file. I get an error message like this:

    The document “hosts” could not be saved. You do not have appropriate access privileges. To view or change access privileges, select the item in Finder and choose File > Get Info.

    I'm already logged into the admin account. I also changed all of the accounts to have Read & Write privileges for the hosts file, but I still encounter the same error.

    I've tried searching the forums for this problem beforehand, but found no solution. All the help you can give me is appreciated. Anyone have any idea how to fix this?
     
  2. Modified! thread starter macrumors newbie

    Joined:
    Oct 17, 2009
    #2
    Excuse my double post, but I have fixed my problem. I ended up dragging the hosts file onto the desktop, editing and saving it there, then replacing the old hosts file. Worked like a charm.

    Feel free to close.
     
  3. mikegoood macrumors newbie

    Joined:
    Nov 24, 2010
    #3
    Love u people!

    It's amazing, how much help I am getting from you guys!!!
     

Share This Page