Trouble sending email via wifi

Discussion in 'iPhone' started by mike7545, Oct 8, 2007.

  1. mike7545 macrumors newbie

    Joined:
    Oct 8, 2007
    #1
    Hi,
    Just checking to see if anyone has a suggestion on sending emails when connected to a wifi network. I can send and receive emails through my Outlook account when connected to the Edge network, but when connected to wifi I can only receive, I can't send emails. Any suggestions on common settings problems that could be causing this?
    Thanks,
    Mike
     
  2. FreeState macrumors 68000

    FreeState

    Joined:
    Jun 24, 2004
    Location:
    San Diego, CA
    #2
    What email server are you using? What kind of email account?

    My guess is your home internet (WiFi) blocks outgoing smtp servers unless it is the ISP's server.

    For example if your ISP is Cox - you can only send email via your Cox internet connection with Cox SMTP server (smtp.west.cox.net or something similar).
     
  3. mike7545 thread starter macrumors newbie

    Joined:
    Oct 8, 2007
    #3
    Email server

    I am experiencing this whether in-house at my workplace or even in public wifi hotspots. Is there a fix to the problem if the server blocks emails that aren't from the ISP's server?
     
  4. BamaATL macrumors member

    Joined:
    Sep 7, 2007
    #4
    The problem with this, at least from my experience, is that the SMTP servers will reject your outbound mail requests if you aren't obtaining your internet connection through them.

    So if you have your email account configured to send email through your ISP SMTP server, it works fine on Wifi from home (assuming you are using that ISP at home). However sending mail via Edge fails because your ISP will reject it.

    On the other hand, if you have your email configured to send via the ATT SMTP server, it works fine on Edge, but sending it via Wifi fails for the same reason above.

    To work around this, I setup a GMail account and only use it to send mail from my iPhone. I can send email using smtp.gmail.com from both Edge and Wifi.

    It works pretty well because you can configure your GMail account to make it appear that you sent it from your work or other ISP email account. So to the receiver of the email, it will appears as if it came from your normal email account (not GMail).
     
  5. alexrb macrumors newbie

    Joined:
    Jan 22, 2008
    #5
    outgoing mail

    But Gmail is not that long with us :)
    I am using a server of smtp.com, started at my laptop and now put the same one into iPhone's outgoing mail settings. It is an independent smtp server, so it works well regardless ISP or location and keeps the from-address to the one you have pop-mail from. Simple and easy!
     
  6. peeaanuut macrumors 65816

    Joined:
    Sep 10, 2007
    Location:
    Southern California
    #6
    I was having the same problem at work and talked to the IT guys. they told me they block port 25 incoming and outgoing requests. So I just go on edge to check my mail and than go back to wifi to surf. Problem solved there.
     

Share This Page