Trouble sending from Mail 5

Discussion in 'Mac Apps and Mac App Store' started by julesmazur, Oct 4, 2011.

  1. julesmazur macrumors newbie

    Joined:
    Sep 5, 2011
    #1
    I used my Gmail email address for almost nine months in Mail 4, and it worked swimmingly. An issue I've gotten lately with Mail 5 in Lion, is that whenever I want to send a message from my primary account, the compose window disappears as it should, but is then followed by a pop-up window from Mail, which disappears before it can be read. I isolated a frame from a ScreenFlow recording of the event, and the message reads, "An error occured while trying to sign this message with a certificate from [myusername]@gmail.com. Verify that your certificate for this address is correct, and that its private key is in your keychain." I've tried going into Mail>Preferences, and changing the security certificate. Nothing. Removing and adding the account again. Nothing. Is there anything else I can do? Receiving emails still works, and both sending and receiving works when I visit Gmail in my browser.
     
  2. Spikestrip macrumors member

    Spikestrip

    Joined:
    Apr 1, 2011
    Location:
    California
    #2
    I am having the same issue with my primary address only. I have two Gmail accounts working fine, and I have a few accounts through GoDaddy working fine as well. Only my default account, a MobileMe/.Mac address I've been using for years, has this problem. I just contacted Apple regarding this and have not gotten a response yet. Funny, I did the same thing you did, recording the screen to see what that error message said, and that's how I found this. Gotta love Google.
     
  3. Spikestrip macrumors member

    Spikestrip

    Joined:
    Apr 1, 2011
    Location:
    California
    #3
    I just got off the chat with Apple. It seems that I had to remove the account in question from Mail's preferences, and then quit Mail. Then I had to go to System Preferences, to the Mail, Contacts, Calendars pane and remove the account from there also. When I put the account back into that prefpane, everything worked, sort of. It appears my problem came from Apple switching over to the me.com servers, and my computer still trying to connect to the mac.com servers. When I set the account back up in the Mail, Contacts, Calendars prefpane, iCal did not like the CalDAV settings that came automatically with that account. I had to open iCal separately and add my MobileMe account as a CalDAV account. I'm guessing Apple migrating services to iCloud is the source of the problem.

    So feel free to try these steps, and please report back here if this works for you. My Mail application is running perfectly now, but given the source of the problem, the same steps may not solve your issue. Good luck!
     
  4. Spikestrip macrumors member

    Spikestrip

    Joined:
    Apr 1, 2011
    Location:
    California
    #4
    Fixed! After another lengthy call to AppleCare, being transferred first to a person in the Mac department from the mobile devices and iCloud department (not their official department names), and then to a Senior Advisor, someone was finally able to dig up an answer. This woman was named Chris, or Krys, or something sounding like that, and she found that digital certificate signing is turned on by default in some cases. The little symbol next to the lock with the check mark is causing the problem. Click it, and you'll see what's in the next image. Solved. Thank you AppleCare. Thank you {C}{Ch}{K}r{i}{y}s{s}
     

    Attached Files:

Share This Page