Trouble SSH'ing into iPhone4 after JB

Discussion in 'Jailbreaks and iOS Hacks' started by devros, Aug 2, 2010.

  1. devros macrumors newbie

    Joined:
    Jan 27, 2008
    #1
    I have the phone all jailbroken and have open-ssh installed. I can telnet to port 22 on the iphone's IP address, but I keep getting timeout errors trying to connect. any suggestions?

    thanks,

    -dev
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    check in Cydia under manage packages to see if it is really installed. I was having a similar problem this morning and had to run the install three times before it worked. Never saw it under manage packages until the third install.
     
  3. devros thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #3
    I know that it is installed, as I get a reply when telnetting to port 22 when the SSH toggle is on, but get no reply when it is off.
     
  4. GeorgeBear macrumors newbie

    Joined:
    Aug 2, 2010
    #4
    Reset network connections, and then turn your router on and off, worked for me.
     
  5. devros thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #5
    no luck. having the same problems, both with a 4.0.1 iPhone 4 and a 3.2.1 iPad, both just JB'ed with the latest jailbreakme method. I can see both devices on my network, but neither one will respond to a ping request.
     
  6. devros thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #6
    another update. now it works on the iPad. still nothing on the iPhone. Can anyone confirm they can ssh into a iPhone 4?
     
  7. byeehaaw macrumors 6502

    Joined:
    May 7, 2007
    Location:
    New York, NY
    #7
    im able to do it on my ip4
     
  8. Niclariv macrumors newbie

    Joined:
    Dec 17, 2009
    #8
    Should I be worried?

    Hmm so I installed openssh but can't get in to it with cyberduck.. Is there a chance apple has changed the root password from alpine to something else?

    Should we be worried about the ikee virus or anything else coming back since if i can't ssh in, i can't install the new beta of terminal, and i can't change the password to my own to guard against that virus?
     
  9. Niclariv macrumors newbie

    Joined:
    Dec 17, 2009
    #9
    haha nevermind, excellent.. I ran Rock since installing SSH and it automatically gave me the option to change the password. Rock on.
     
  10. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #10
    You can use RockApp to change your password. Download it from Cydia.
     
  11. suade8880 macrumors member

    Joined:
    Jun 22, 2010
    #11
    I was able to do it on my first try. I use WinSCP.
     
  12. doboy macrumors 68000

    Joined:
    Jul 6, 2007
  13. ryan0402 macrumors 6502

    Joined:
    Jul 24, 2010
  14. bobbytallant macrumors 6502

    Joined:
    Apr 6, 2010
    #14
    Guys also having trouble with OpenSSH.

    Am I being really dense here or do I remember that there should be an actual app for this after install with the fish icon etc and then you can activate it to be open to be ssh'ed?

    I just install it from Cydia, it says its installed in my packages and I cannot see an icon for it in on the home screen??? I have literally installed it and reinstalled like 20 times and can see nothing...

    Am I missing something here - is there even an app for it or is it just permanently open to be ssh'ed without the need for an app/icon/activation lol??

    I know I had this last year on my 3GS...? I'm using iPhone 4 on 4.1 :confused:
     
  15. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #15
    It doesn't have an icon and it's on by default. You can use the toggle in sbsettings to toggle it on and off.
     
  16. bobbytallant macrumors 6502

    Joined:
    Apr 6, 2010
    #16
    Excellent. Thanks!
     
  17. doctapeppa macrumors 6502

    Joined:
    Jun 15, 2008
    #17
    I can SSH into my phone after I install OpenSSH one time but after I close the connection I cannot SSH into it again unless I reinstall OpenSSH. Resetting network settings doesn't work. Clearing my keys on my mac doesn't work either. The error I get on the terminal is "remote server closed the connection" or something like that

    Iphone 4 on 4.0
     
  18. germanguy macrumors regular

    Joined:
    Sep 15, 2008
    #18
    Same problem here. Password not accepted (alpine). I assume "username" is blank, correct?
     
  19. scotty588 macrumors 6502

    Joined:
    Jan 2, 2007
    Location:
    Carlsbad, CA
    #19
    Username is root
     
  20. RyanOnymous macrumors newbie

    Joined:
    Aug 7, 2010
    #20
    Having issues with SSH on IP4.0.1 as well. Had a touch on 3.1 that I was able to use finder's Connect to Server command and mount in Finder, doesn't work on the 4. SBSettings tells me OpenSSH is on. WiFi Web Server options in iFile tells me the device will receive on IP 10.0.1:10000. I can SSH into it in Terminal too, i just don't know how to move a file to it that way. All I want to do is move the Jailbreakme .pdf warning patch to it!
     
  21. ellsworth macrumors 6502a

    Joined:
    Jun 13, 2007
    #21
    When I ssh into my iphone 4 with Fugu I get: " @ WARNING: REMOTE HOST IDENTIFICATION HAS BEEN CHANGED! @" Bummer
     
  22. blazinz macrumors regular

    Joined:
    Jun 15, 2010
    #22
    where do you go for sbsettings.. i thought it had an icon:confused:, i cant seem to find it, n ive removed and installed it few times and cant find it anywhere..:eek:
     
  23. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #23
    It might be that you typed it wrong but that is not an example of an ip address you provided it should look like this xx.xx.xx.xx:yy where YY is the port number.
     
  24. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #24
    You don't need openssh to install terminal go to CYDIA , manage, sources, edit, add then add source http://cydia.xsellize.com/ and search for "mobile terminal ios4" install it and you are done.
     
  25. ellegi macrumors newbie

    Joined:
    Aug 10, 2010
    #25
    reinstall ssh through cydia, enter in ssh and verify if is present the file /bin/poc-bbot

    if is present your iphone could be infected by worm ikee that kill your ssh at regular interval.

    Let me know if this is your problem. I had the same problem with iphone4 and with removal procedure seems to work fine.
     

Share This Page