Trouble staying logged in - Safari

Discussion in 'Mac Basics and Help' started by MadDog31, Dec 25, 2008.

  1. MadDog31 macrumors 6502a

    Joined:
    May 20, 2007
    #1
    Hey all,

    I tried doing a search to really no avail. I'm having an issue where Safari isn't keeping me logged into forums and other Web sites even though I'm not manually logging out.

    It seems as though this problem started with 10.5.6 but it could be just coincidence. I've tried resetting Safari to no avail. Any solutions?

    Ian
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    If resetting Safari doesn't do the trick, consider removing the Safari plist from ~/Library/Preferences. Note that this will reset your home page to the Apple Start page from whatever it may have been, and re-enable your Bookmarks/Status bars if you disabled them.
     
  3. wakanomori macrumors newbie

    Joined:
    Dec 26, 2008
    #3
    See this thread too

    There's definitely something VERY fishy going on with Safari 3.2.1 and OS X 10.5.6 -- see more at this thread:

    "Safari keeps logging me out of Facebook"

    I'm wondering if it's the "anti-phishing" preference -- I did NOT try unchecking this one before I deleted Safari, and I wonder if anyone has any feedback on that as it affects this particular bug. . .
     
  4. MadDog31 thread starter macrumors 6502a

    Joined:
    May 20, 2007
    #4
    I'd be willing to try it out for the sake of the thread.

    Is it the "Warn when visiting a fraudulent Web site" setting?
     
  5. wakanomori macrumors newbie

    Joined:
    Dec 26, 2008
    #5
    Yes, that's the one. So far I've done a full flushing of caches and resetting permissions (using YASU), reset the PRAM, deleted Inquisitor and Saft (both are add-ons, which some people suggest as the cause of Safari weirdness; I don't think I have any other add-ons that aren't very generic, such as Quicktime, WMV, etc.), and turned off that "fraudulent sites" button, after reinstalling Safari from a fresh download. I'll post again on how it behaves. . .
     
  6. dvkid macrumors regular

    Joined:
    Feb 18, 2006
    #6
    Any update on this? I'm having the same issue and am about to try the same thing.
     

Share This Page