Trouble syncing

Discussion in 'iPod touch' started by FunkyFreshBoy, May 3, 2008.

  1. FunkyFreshBoy macrumors newbie

    Apr 22, 2008
    Just bought a Touch. I hook it up to my computer and it's not being read by Itunes. So basically I can't sync it or do anything. Please shed some light on this computer illerteriate person haha! Thanks guys
  2. Brian513A macrumors member

    Oct 14, 2007
    I've just had the same problem with mine starting last night - and it's completely random too. In the rare event that I can actually get my computer to recognize that my touch is plugged in (I've been having to restart my PC in order for iTunes to recognize it) while I try to transfer or delete music from my touch, I get a consistent error message saying that iTunes cannot "read/write the iPod disk"... I'm very confused and can't figure it out.
    Anyone out there happen to know what's going on and a possible solution?
  3. Dukie macrumors newbie

    May 6, 2008
    Gosh that makes 3 of us. I bought my 32MB Touch on last Saturday. I was able to physically move my music and videos by creating a new iTunes folder and just dropped abd dragged. Now I'm still trying to fix the mess.

    Basically I had a 5G iPod before upgrading to the iTouch.
  4. Drucifer macrumors regular

    Apr 28, 2008
    When I got my iPod Touch I had the same problem. I even spent time updating iTunes before trying to connect it.

    Turns out iTunes needs a certain driver to allow the Touch to connect so what I did was un-install iTunes (I actually un-installed all Apple software such as Quick Time).

    I then restarted and re-installed the new version of iTunes from the Apple site and it worked first time.
  5. Brian513A macrumors member

    Oct 14, 2007
    ALRIGHT, I finally just got it. That was hell. Here's what happened: I uninstalled/reinstalled iTunes to no avail. After that, I uninstalled everything Apple related except for Quicktime - this includes Apple Mobile Device Support and iPod Service Helper. I'm very positive this is what screwed me over in the first place. Next I reinstalled the iTunes package. My computer was now recognizing when I plugged in my iPod Touch, but iTunes wasn't launching at all. After playing around with it for hours, I fully disabled PeerGuardian2 (Don't know if this has to do with anything but it's what helped in the end) and re-set the permissions for iTunes and Apple Mobile Device Support through Comodo Personal Firewall Pro and iTunes had no problem launching. I'm pretty sure that for those of us with Touches, the AMDS (Mobile Device Support) is what has to be fully working to get our PC's to know that we plug in our iPods. Make sure you completely remove this from windows and then try reinstalling it. I hope this can help! Good luck. If you have any more questions, feel free to message me.
  6. Brian513A macrumors member

    Oct 14, 2007
    Just tried it out again -- it's definitely PG2 that's blocking iTunes from launching, which extremely odd because PG2 is an IP blocker, not a program blocker. There isn't anything else that could be blocking it so I'm not sure what else it could be other than that. Those of you using PG2 may want to completely disable it and see if that helps the problem.

Share This Page