Trouble Using Greek Fonts

Discussion in 'Design and Graphics' started by teddy.horan, Jan 29, 2010.

  1. teddy.horan macrumors newbie

    Joined:
    Jan 29, 2010
    #1
    Hello,

    I am not sure if this post belongs here but I need help.

    I am having difficulty installing a Greek Font. When I go to install it nothing appears in the install box. And when I use the font in IPages only english letters are produced. This is the font I am using. Is there a certain application I need to use this font with IPages? Thanks for your help.
     
  2. sigmadog macrumors 6502a

    sigmadog

    Joined:
    Feb 11, 2009
    Location:
    near Spokane, WA
    #2
    Did you copy the uncompressed font files into Users/YOUR-USER-NAME/Library/Fonts?

    That should be all that's required, I should think.
     
  3. teddy.horan thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #3
    I have tried that. All I am getting is English letters.
     
  4. sigmadog macrumors 6502a

    sigmadog

    Joined:
    Feb 11, 2009
    Location:
    near Spokane, WA
    #4
    Okay, I just tried it on mine and it doesn't work either.

    I even added it to my font manager and tried it in Illustrator and it's not available.

    I suspect it may be a broken font, or at least not compatible with Mac's in some way.

    The documentation doesn't help at all, either. I'd suggest looking for another font that plays well with Macs.

    EDIT TO ADD:
    I solved it - see my note below.
     
  5. teddy.horan thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #5
    Thank you sir. That is exactly what I wanted to find out.
     
  6. sigmadog macrumors 6502a

    sigmadog

    Joined:
    Feb 11, 2009
    Location:
    near Spokane, WA
    #6
    I think I may have a solution.

    Go to your System Preferences and select Language and Text, then select the Input Sources tab and check the "Greek Polytonic" box (make sure that "Show input menu in menu bar" is checked also at the bottom of the window).

    Then you can select which language you will type in from the top-right of the desktop menu.

    I did that, and suddenly, the font came alive in Pages and in all my other apps.

    Sorry I didn't think of this sooner. I used to use Greek fonts all the time.
     
  7. teddy.horan thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #7
    That fixed it. Thank you again sir. Best wishes.
     

Share This Page