Trouble with Fedora DVD on G4

Discussion in 'PowerPC Macs' started by Glow-worm, Aug 12, 2012.

  1. Glow-worm macrumors newbie

    Joined:
    Aug 12, 2012
    #1
    I've spent the last 3 weeks searching around the net trying to figure out what I'm doing wrong (and right) and have found bits and pieces of info but still haven't put together a solution. I'm somewhat still new to Linux and haven't had any previous experience with burning iso images.

    I took a 10 week course on Linux several years ago and recently dug out my book and decided to try to pick it up again. I'd like to familiarize myself with the Linux environment and get some more experience with it. The book covers Fedora 8 and so that's the distro I would like to stick with. Unfortunately the disc that came with it was meant for PC's or x86 or something. Since I have a G4 I searched the net for a ppc version and found one at:

    http://archive.fedoraproject.org/pub/archive/fedora/linux/releases/8/Fedora/ppc/iso/

    I verified the iso using Terminal (Darwin) with a command I found online:

    $ /usr/bin/openssl sha1 /Users/name/Desktop/Fedora-8-ppc-DVD.iso

    returns: SHA1(/Users/name/Desktop/Fedora-8-ppc-DVD.iso)= d4a12f8864eaccf09bf3a8790bd8d6b758b72f64

    That matches both the sha1sum on the web page and also the same one found in my book, but....

    If I open disk utility and drag the iso file into left pane and click the verify icon up top I get:

    Unable to verify "Fedora-8-ppc-DVD.so". This image has no checksum information to verify.

    If I click the verify disk button below I get:


    Verifying volume “Fedora 8 ppc DVD”
    Checking HFS volume.
    Invalid number of allocation blocks
    The volume needs to be repaired.

    Error: The underlying task reported failure on exit


    1 HFS volume checked
    Volume needs repair

    So now I'm confused to whether this is a good iso or not. If I double-click the iso file it opens with the warning "The disk image you are opening may be damaged and could damage your system." I open it with no problems though. Is this the same as mounting?

    If I try to open from disk utility I get:

    Unable to attach "Fedora-8-ppc-DVD.iso" - no mountable file system.

    But yet when I double-click to open it there are files inside I can actually open...

    Some specs:

    Hardware Overview:

    Machine Name: Power Mac G4 (AGP graphics)
    Machine Model: PowerMac3,1
    CPU Type: PowerPC G4 (2.8)
    Number Of CPUs: 1
    CPU Speed: 400 MHz
    L2 Cache (per CPU): 1 MB
    Memory: 640 MB
    Bus Speed: 100 MHz
    Boot ROM Version: 4.2.8f1


    ATA Bus:

    HITACHI DVD-ROM GD-3000:

    Model: HITACHI DVD-ROM GD-3000
    Revision: 020S
    Serial Number:
    Detachable Drive: No
    Protocol: ATAPI
    Unit Number: 0
    Socket Type: Internal


    I can't burn DVD's on this so I copied the iso file to an external usb hard drive and moved to father's computer. We used disk utility. Dragged and dropped iso file into left pane of disk utility selected it and hit burn. Which from the multitude of forums I've read seems to be the correct procedure to burn images rather than the iso file itself.

    It's burnt onto a Verbatim DVD-R disc, which from what I've searched online should be the correct format for my HITACHI DVD-ROM GD-3000. However it just keeps ejecting the disc. If I'm in OSX it ejects. If I hold down "C" during startup it ejects and loads OSX.

    Holding option during startup gave me a black screen. Then I found out holding command-option P+R, then holding option (or loading open firmware) works without the black screen afterwards. It has something to do with my monitor, but not really sure if there's a setting in OSX preferences to fix this (it's a widescreen monitor so probably some goofy resolution resizing thing). Unfortunately the only option is OSX, doesn't recognize the DVD.

    The drive seems to work fine, I've inserted other discs just fine. In fact the disc that came with the book I can open in OSX, I just can't boot from it since it's not the ppc version. I don't know why I can't get my burnt disc to load in OSX however, I should be able to view it just like my mounted iso file right?

    My next big headache if I ever solve this one is I don't have much room left on the main hard drive, I do however have a fire wire external drive I was planning to install Linux on. I hear that it can be a pain to boot to that as well, but one headache at a time.

    Any help would be much appreciated as I'm currently stumped as what to do next.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Can the drive read other DVD discs? Some G4 era drives lose the ability to read DVDs as they get older. The fix for this is to replace the drive.
     
  3. Glow-worm thread starter macrumors newbie

    Joined:
    Aug 12, 2012
    #3
    I just grabbed a DVD (Gladiator) off the shelf and it played just fine. Also I found some specs for this model here:

    http://reviews.cnet.com/dvd-drives/hitachi-gd-3000-dvd/4507-3212_7-32154059.html

    It lists DVD-R which is what I used, so there shouldn't be a problem there.

    I really don't know what to think. I don't know if I have a bad iso file, or if I have a badly burned DVD...

    Are those disk utility messages normal for a Linux iso? It mentions a bad HFS volume, but Fedora 8 uses ext2 so I thought maybe that was just the mac's interpretation of a bad HFS volume?

    Like I said I don't have any experience burning iso images (or anything else for that matter) so I'm not sure what is expected here.

    I would really like to stick to Fedora 8 as that is what my book covers. I'm also leery to download another iso until I get to the root of the problem. It took 5-6 hours for it to download plus another 2 or more hours to copy to my father's external usb drive to burn on his computer.
     
  4. Glow-worm thread starter macrumors newbie

    Joined:
    Aug 12, 2012
    #4
    Just an update if anyone is still interested (I haven't given up completely yet). I downloaded and burned Yellow Dog Linux 6.2 onto a DVD. I read somewhere Yellow Dog Linux was designed with ppc in mind. Anyway I ran into all the same problems. I tried both my Fedora 8 and YDL discs in my father's computer and they both appeared on the desktop with files inside, so I know the discs aren't bad. So it turns out that both the internal and external CD/DVD drives I have attached to my G4 just don't like the discs.

    I grabbed my CD/DVD drive from my iBook (it's firewire) and Voila they load. When I restart and hold option key I get the choice of MacHD or an icon with a Disc and Tux in the lower right corner. When I select it and hit the forward arrow however the screen goes black for like two seconds (it sounds like it attempts to do something) then immediately returns to the previous screen.

    Upon some more internet searching I've discovered I'm not the only one to have this problem, unfortunately none of the threads I've read on this topic seem to come up with a good solution. It seems like G4's just have a lot of issues when it comes to installing Linux. I know it's possible though and I'm not ready to give up.

    I read somewhere that booting from Open Firmware is a better option, I've tried:

    Code:
    boot cd:\install\yaboot
    and I've tried:

    Code:
    boot cd;,\\:tbxi
    both of which failed to work. I don't know if those commands search all the drives or if maybe it just looks at the internal drive. Does anyone know any commands to boot from a specific device?
     
  5. MacinDan macrumors regular

    Joined:
    Jun 26, 2010
    #5
    I didn't know people still used Yellow Dog Linux on Macs. And distributions as old as Fedora 8 didn't have good support for PowerPC.

    IMO the only distros worth trying on Macs are Debian-based ones. That would be Debian, Ubuntu and all its derivatives, and MintPPC. I myself use Debian Wheezy with Openbox on an iBook G3 700 MHz with 256 MB of RAM, and I can run Iceweasel (Firefox) 10 with other applications open simultaneously and have no speed hiccups. This was not possible in Tiger. There's no question that Linux with the right GUI for your hardware is much faster.
     

Share This Page