Trouble with file extensions

Discussion in 'Mac OS X Lion (10.7)' started by rupam.db, Jun 4, 2012.

  1. rupam.db, Jun 4, 2012
    Last edited: Jun 4, 2012

    rupam.db macrumors member

    Joined:
    May 29, 2012
    #1
    Before I installed "The Unarchiver" exe files just showed a black icon...
    After installing it the unarchiver tries to open it and fails every time. So I unchecked the file association for windows executive files in the unarchiver preferences... still exe files were associated with unarchiver. So deleted it. Now every time I double click the exe file it opens up in textedit....I know exe files are not supported in mac. I just want the default file association settings that the unarchiver messed up with...



    So I tried this command but still no changes...

    Code:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    Somebody please suggest me a solution. Also can somebody explain the command?
    Thanks in advance :)
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Do command-i on an .exe file and in the Open with area change it to whatever you want (mine shows only Unarchiver and App Store or Other... as options). Then click change all.
     
  3. rupam.db thread starter macrumors member

    Joined:
    May 29, 2012
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    TextEdit is the default, as Mac OS X doesn't recognize .exe files as an executable file type.
     
  5. iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #5
    Unarchiver is associated with EXE files by default because some EXE files are self-extracting files (on windows) and Unarchiver can extract those files on a Mac.

    But regular windows programs (what most .exe files are) can't run on Macintosh.

    If you wan to run them, you either have to get Parallels or VMware to run windows or setup bootcamp to boot into Windows.
     

Share This Page