Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Sakurambo-kun

macrumors 6502a
Original poster
Oct 30, 2015
572
672
UK
I a few devices connected to my Pioneer AV receiver, a Sony UHD bluray player, a PS4 Pro, a Switch, and an Apple TV 4K (which I've just upgraded to from an ATV 4).

I use HDMI-CEC to turn on my TV and receiver at the same time as whatever device I'm using. All of them work fine, except the Apple TV. It sometimes works, perhaps one of of every 10 times I use it. Mostly though it doesn't work and I have to manually turn everything on. When I go into the settings screen of the Apple TV when HDMI-CEC hasn't worked, I see that HDMI-CEC is off and it won't let me turn it on. Both my 4K ATV and my previous ATV 4 had exactly the same issue.

Not a huge deal, but kind of annoying. I thought it could be some odd incompatibility with my receiver, but even plugging the ATV directly into my TV (LG B7) made no difference.

Had anyone else had any issues?
 
  • Like
Reactions: Donfor39

Donfor39

macrumors 68000
Jul 26, 2012
1,899
372
Lanarkshire Scotland
I find Apple t.v. Takes a while to boot from power on.
HDMI-CEC is working via Sky-hdmi1+ap4ktv-hdmi2.
If I press the tv symbol button via siri remote it does switch on aptv+t.v. Switches to hdmi2 aka ap4ktv.
I find it seasier to sleep ap tv if I want to press Sky button to switch to hdmi1. Aka Sky.
Can’t say I’ve had any probs other than initial power on.
Though I think that’s more Sony t.v related rather than hdmi cec.
 

priitv8

macrumors 601
Jan 13, 2011
4,049
642
Estonia
I have everything Sony, except aTV 4K and Arris IPTV box.
My aTV loses CEC as well every now and then.
Then I need to reboot it to get CEC back for undetermined time.
I am still unsure if its aTV or Arris, but one of them has problems with CEC protocol.
I have an impression that iOS 11 made things worse, not better.
 
Last edited:

Lammers

macrumors 6502
Oct 30, 2013
449
345
My Apple TV 4th-gen was flawless in the HDMI-CEC department, but the new 4K has been very troublesome. It seems to regularly revert back to control being “Off” and I need to restart the 4K ATV in order to restore the functionality. :-(
 

borrachomoe

macrumors newbie
Jan 27, 2009
8
0
My Apple TV 4th-gen was flawless in the HDMI-CEC department, but the new 4K has been very troublesome. It seems to regularly revert back to control being “Off” and I need to restart the 4K ATV in order to restore the functionality. :-(

I have the exact same issue. Apple TV 4th-gen worked perfectly with HDMI-CEC but the new 4K has trouble. 4K ATV reverts back to “off” almost every time after using it. I have to reset the ATV via settings or unplug and plug back the phone charging cable for it to work.
 

borrachomoe

macrumors newbie
Jan 27, 2009
8
0
Has anybody tried taking the ATV 4K back to the Apple Store and getting it fix or a replacement?
 

Sakurambo-kun

macrumors 6502a
Original poster
Oct 30, 2015
572
672
UK
What’s with the black screen via 11.2

Slightly annoying for a few secs

Do you have Match content enabled? If you do, your TV will be switching modes to match the frame rate and dynamic range of the content. That will black the screen for a few seconds.
 

priitv8

macrumors 601
Jan 13, 2011
4,049
642
Estonia
What’s with the black screen via 11.2
Slightly annoying for a few secs
As Sakurambo-kun mentioned, it must be because of the dynamic switching has been enabled.
Now you see why Apple called this thing "inelegant" in their keynote.
Here, only a faster-reacting (ie faster-processing) screen will help.
 
Last edited:
  • Like
Reactions: Donfor39
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.