Trouble with iMessages

Discussion in 'iOS 11' started by beachmusic, May 22, 2018.

  1. beachmusic macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
    #1
    Not sure this is the right place but here goes. I have a problem with iMessages on my iPhone 7plus, iPad Pro, and 2016 iMac. I can receive messages and they showup on all devices at the same time. But when I send a message it only show on the device I send it from. I have followed a bunch of google suggestion but nothing seems to work. Also signed out of iCloud on all devices and signed back in. No help. don't know what to try next.
     
  2. bradbomb macrumors 6502

    bradbomb

    Joined:
    Jan 7, 2002
    Location:
    Los Angeles, CA
    #2
    How long have you had the problem? Are you or have you run beta or Public Beta OS on any of your device? Maybe you accidentally enabled iMessages in the cloud or something.
     
  3. beachmusic thread starter macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
    #3
    Thanks for getting back. It was working and just stopped. No beta's.

    Now my android friends are not receiving my messages.
     
  4. bradbomb macrumors 6502

    bradbomb

    Joined:
    Jan 7, 2002
    Location:
    Los Angeles, CA
    #4
    Ok a couple of things I can think of. Check the Text Message Forwarding setting on the iPhone. That would need to be setup correctly to send SMS from your iPad or Mac. As for iMessage in general. Check to see in the settings if it still says Waiting for Activation on your devices. I've had times where I had to disable iMessage an re-enable because it was stuck on waiting for activation.
     
  5. beachmusic thread starter macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
    #5
    Ok figured it out. someone in my family put my number on the block list. Thanks again
     

Share This Page