Trouble With Keyboard Shortcuts

Discussion in 'macOS' started by steiney, Oct 31, 2013.

  1. steiney macrumors 6502

    Joined:
    Nov 6, 2009
    #1
    Hello all,

    I suspect I'm going to feel like an idiot for asking this question, but it's driving me crazy.

    I've never been able to get custom OSX keyboard shortcuts to work since Tiger on my first Mac. I've tried several times over the years to get custom shortcuts to work with no luck.

    I am doing everything exactly as requested by Apple, and I get the drop menu containing the menu item to flash blue when I hit the keyboard shortcut after that. And the keyboard shortcut appears next to the menu item in the dropdown after I have created it. I just don't know why it never actually performs the function.

    Currently, I was just reminded of this problem because I tried to define Shift+Command+S to be "Save All..." in Thunderbird and remember the problem because I, of course, could not get it to work.

    If anyone has any ideas or sees what I'm doing wrong, input would be greatly appreciated!

    Thanks in advance,

    steiney
     
  2. sfwalter macrumors 68000

    sfwalter

    Joined:
    Jan 6, 2004
    Location:
    Dallas Texas
    #2
    When you are specifying the menu title are you type three periods or using the ellipse symbol? Three periods won't work. After typing "Save All" you need to press option ;

    The option ; produces the ellipse symbol.
     
  3. steiney thread starter macrumors 6502

    Joined:
    Nov 6, 2009
    #3
    I thought of that. I tried entering the ellipses using the special characters menu, but it's actually written as three periods in Thunderbird and it's all about matching the menu item exactly. The ellipses didn't work.

    With the three periods, the menu flashes blue when I press the shortcut and the shortcut appears written out next the the title of the menu item in the menu. When I use the ellipses, neither of those things happens.
     
  4. bernsense macrumors newbie

    Joined:
    Dec 15, 2013
    #4
    I don't know if you've figured it out by now, but have you tried using the FULL menu command, like File->Save All... instead of just Save All...

    Some apps require that...
     
  5. steiney thread starter macrumors 6502

    Joined:
    Nov 6, 2009
    #5
    Oh, no. I was not aware of that. I had just tried "Save All..." and the same with the ellipse character and gave up. I just tried your suggestion but it still doesn't work. :(
     

Share This Page