Trouble with ML links

Discussion in 'Mac Apps and Mac App Store' started by Beachguy, Jul 25, 2012.

  1. Beachguy macrumors 6502a

    Beachguy

    Joined:
    Nov 23, 2011
    #1
    No, not 404 or other error messages.

    I fill out the form to get the upgrade for one of my qualifying Macs (I have two- MBA, and MBP) and click to continue after putting in my purchase date, it redflags my number of qualifying systems and won't let me continue.

    I'm going by the order date I have for the Macs from the sales receipt in the Apple Store. Any ideas why it won't let me go further? It's not acting like there is a traffic issue- it is simply not going on to the next page.
     
  2. fanchee macrumors 6502a

    fanchee

    Joined:
    Nov 23, 2009
    #2
    I went through the process this morning, and I wasn't exactly sure what "Right to Copy" meant, so I left that completely blank (after trying to check it and putting 1 in the number of systems box, and being red-flagged, too). So I left that part unchecked and blank, and it let me continue.

    Perhaps you need to complete the form twice, once for each serial number?

    Now I'm wondering how long it'll take to generate a link for me. It's been a couple of hours already.
     
  3. Beachguy thread starter macrumors 6502a

    Beachguy

    Joined:
    Nov 23, 2011
    #3
    I have no idea about what it meant either. I'll try to do it without.

    --Later--

    Bingo! That was it! Thanks... :)
     
  4. fanchee macrumors 6502a

    fanchee

    Joined:
    Nov 23, 2009
    #4
    Well I just now received my link to download, so it didn't take that long, after all!
     
  5. Beachguy thread starter macrumors 6502a

    Beachguy

    Joined:
    Nov 23, 2011

Share This Page