trouble with RAM in MacBook Pro mid-2014

Discussion in 'MacBook Pro' started by mackeenzieee, Feb 2, 2017.

  1. mackeenzieee macrumors newbie

    Joined:
    Feb 2, 2017
    #1
    Hi there, just wondering if you guys have any recommendations on what I can do to help my Macbook out. It's been really weird lately providing all kinds of RAM/disk space/etc. errors. I see EtreCheck posted in many places and have placed my results below. I've had weird "kernel_task" issues almost.. forever, but they've always been intermittent. I've tried googling everything up until this point with little success.

    TIA for any advice/assistance.

    EtreCheck version: 3.1.5 (343)

    Report generated 2017-02-02 22:02:29

    Download EtreCheck from https://etrecheck.com

    Runtime 1:37

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Problem: Beachballing

    Description:

    I’ve been having issues for the past 2 days with my computer saying that I do not have enough space available, where I can’t even use the clipboard. I run tight but there are about 10 free gbs on my computer right now, and I do not understand why this is suddenly happening. Additionally, kernel_task seems to be doing a lot of crazy things.





    Hardware Information:

    MacBook Pro (Retina, 15-inch, Mid 2014)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro11,2

    1 2.2 GHz Intel Core i7 (i7-4770HQ) CPU: 4-core

    16 GB RAM Not upgradeable

    BANK 0/DIMM0

    8 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    8 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 414


    Video Information:

    Intel Iris Pro

    Color LCD 2880 x 1800


    System Software:

    macOS Sierra 10.12.2 (16C67) - Time since boot: about 9 hours


    Disk Information:

    APPLE SSD SM0256F disk0 : (251 GB) (Solid State - TRIM: Yes)

    [Show SMART report]

    EFI (disk0s1) <not mounted> : 210 MB

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    Macintosh 10.10 (disk1) / [Startup]: 249.77 GB (14.70 GB free) (Low!)

    Core Storage: disk0s2 250.14 GB Online


    USB Information:

    Apple Inc. Apple Internal Keyboard / Trackpad

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Gatekeeper:

    Mac App Store and identified developers


    Kernel Extensions:

    /Applications/BlueStacks.app

    [not loaded] com.bluestacks.kext.Hypervisor (4.3.26 - 2015-07-30) [Support]



    /Applications/Transmit.app

    [not loaded] com.panic.TransmitDisk.transmitdiskfs (4.0.0 - SDK 10.6 - 2014-10-09) [Support]



    System Launch Agents:

    [not loaded] 7 Apple tasks

    [loaded] 174 Apple tasks

    [running] 71 Apple tasks

    [killed] 28 Apple tasks

    28 processes killed due to insufficient RAM


    System Launch Daemons:

    [not loaded] 42 Apple tasks

    [loaded] 168 Apple tasks

    [running] 86 Apple tasks

    [killed] 15 Apple tasks

    15 processes killed due to insufficient RAM


    Launch Agents:

    [loaded] com.google.keystone.agent.plist (2017-01-13) [Support]

    [loaded] com.oracle.java.Java-Updater.plist (2017-01-17) [Support]


    Launch Daemons:

    [loaded] com.BlueStacks.AppPlayer.bstservice_helper.plist (2016-07-13) [Support]

    [loaded] com.adobe.fpsaud.plist (2016-12-16) [Support]

    [loaded] com.google.keystone.daemon.plist (2017-01-23) [Support]

    [loaded] com.microsoft.office.licensing.helper.plist (2010-08-25) [Support]

    [loaded] com.oracle.java.Helper-Tool.plist (2016-12-13) [Support]


    User Launch Agents:

    [loaded] com.BlueStacks.AppPlayer.Service.plist (2016-07-13) [Support]

    [loaded] com.BlueStacks.AppPlayer.UninstallWatcher.plist (2016-09-10)

    [failed] com.BlueStacks.AppPlayer.Updater.plist (2016-07-13) [Support]

    [running] com.spotify.webhelper.plist (2016-09-24) [Support]


    User Login Items:

    Flux Application

    (/Applications/Flux.app)


    Internet Plug-ins:

    FlashPlayer-10.6: 24.0.0.194 - SDK 10.9 (2017-01-10) [Support]

    QuickTime Plugin: 7.7.3 (2017-01-06)

    Flash Player: 24.0.0.194 - SDK 10.9 (2017-01-10) [Support]

    AdobePDFViewer: 10.0.0 (2015-05-07) [Support]

    SharePointBrowserPlugin: 14.6.2 - SDK 10.6 (2016-03-25) [Support]

    PepperFlashPlayer: 24.0.0.194 - SDK 10.9 (2017-01-10) [Support]

    Google Earth Web Plug-in: 7.1 (2015-08-25) [Support]

    Silverlight: 5.1.50901.0 - SDK 10.6 (2016-10-31) [Support]

    JavaAppletPlugin: Java 8 Update 121 build 13 (2017-01-17) Check version



    Safari Extensions:

    Ebates Express Cash Back - ebates.com - http://www.ebates.ca/ (2016-10-21)


    3rd Party Preference Panes:

    Flash Player (2016-12-16) [Support]

    Java (2017-01-17) [Support]


    Time Machine:

    Time Machine not configured!



    Top Processes by CPU:

    6% WindowServer

    4% kernel_task

    3% com.apple.WebKit.WebContent(2)

    2% coreaudiod

    2% fontd


    Top Processes by Memory:

    1.17 GB kernel_task

    606 MB com.apple.WebKit.WebContent(2)

    393 MB mdworker(23)

    246 MB Safari

    98 MB Activity Monitor


    Virtual Memory Information:

    11.82 GB Available RAM

    9.15 GB Free RAM

    4.18 GB Used RAM

    2.68 GB Cached files

    155 MB Swap Used


    Diagnostics Information:

    Feb 2, 2017, 08:36:48 PM /Library/Logs/DiagnosticReports/Safari_2017-02-02-203648_[redacted].cpu_resource.diag [Details]

    /Applications/Safari.app/Contents/MacOS/Safari

    Feb 2, 2017, 05:32:24 PM ~/Library/Logs/DiagnosticReports/VLC_2017-02-02-173224_[redacted].crash

    org.videolan.vlc - /Applications/VLC.app/Contents/MacOS/VLC

    Feb 2, 2017, 04:30:28 PM /Library/Logs/DiagnosticReports/Safari_2017-02-02-163028_[redacted].cpu_resource.diag [Details]

    Feb 2, 2017, 02:46:53 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2017-02-02-144653_[redacted].cpu_resource.diag [Details]

    /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.Plugin.64.xpc/Contents/MacOS/com.apple.WebKit.Plugin.64

    Feb 2, 2017, 12:20:57 PM Self test - passed

    Feb 2, 2017, 05:13:12 AM /Library/Logs/DiagnosticReports/Safari_2017-02-02-051312_[redacted].cpu_resource.diag [Details]

    Feb 2, 2017, 01:25:04 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2017-02-02-012504_[redacted].cpu_resource.diag [Details]

    Feb 1, 2017, 10:59:43 PM /Library/Logs/DiagnosticReports/Java Updater_2017-02-01-225943_[redacted].crash

    com.oracle.java.Java-Updater - /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Java Updater.app/Contents/MacOS/Java Updater

    Feb 1, 2017, 01:14:23 PM /Library/Logs/DiagnosticReports/Safari_2017-02-01-131423_[redacted].cpu_resource.diag [Details]

    Feb 1, 2017, 02:04:34 AM ~/Library/Logs/DiagnosticReports/com.apple.WebKit.WebContent_2017-02-01-020434_[redacted].crash

    /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent
     
  2. tubeexperience macrumors 68030

    Joined:
    Feb 17, 2016
    #2
    The drive is too full.

    You need to either remove something from drive or replace it with a bigger drive.
     
  3. mackeenzieee thread starter macrumors newbie

    Joined:
    Feb 2, 2017
    #3
    So you feel it's just an actual HD space issue? Approximately how much do you feel needs to be clear at any given time? I tend to do light work on video files semi-frequently, so I can definitely quite a bit from my HD, but I've never had any issues like in the past 2 years or so, while operating the same way.
     
  4. ZapNZs macrumors 68000

    ZapNZs

    Joined:
    Jan 23, 2017
    #4
    Have you performed a RAM test using something like Rember or the Apple Diagnostic Test? (these check for actual RAM failure)

    Are you experiencing actual kernel panics?

    Have you tried freeing disk space to see if this results in any changes? OS X uses free disk space for a variety of tasks, such as swap tasks. Some Apps, when running, will also use free disk space for a variety of tasks. If there is insufficient space for these swap tasks, the OS might start killing certain processes?
     

Share This Page