Trouble with restoring...

Discussion in 'Jailbreaks and iOS Hacks' started by ainjo1919, Aug 18, 2010.

  1. ainjo1919 macrumors regular

    Joined:
    Mar 3, 2008
    #1
    So I was trying to restore my iPhone 4 yesterday. I couldn't do it with tiny umbrella it kept giving me an error each time I tried doing it. So I tried editing the host with terminal and it went through, at least up until my phone was almost done restoring with the Apple logo and the loading bar on the screen and then iTunes said it couldn't be restored, and then my phone wen back into recovery mode.

    Then I launched tiny umbrella again and kicked out phone out of recovery. Then the phone booted and was restored.

    My questions are, did restore correctly? I rejailbreaked it and everything seems normal but I don't understand why didn't iTunes fully finished the restoring proccess? And why didn't umbrella worked? I have my shsh backed up with Cydia.
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Probably, you almost always have to kick these phones out of recovery mode when they finish up.
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #3
    Yes, perfectly normal. If you downgrade your firmware, you must kick your device out of recovery mode.
     

Share This Page