Trouble with SMTP server and Mail under Yosemite

Discussion in 'OS X Yosemite (10.10)' started by Orinks, Jul 27, 2014.

  1. Orinks macrumors newbie

    Joined:
    Jul 27, 2014
    #1
    Hi all,
    I am liking Yosemite so far, however ever since Mail set up an iMap Gmail account, every time I try to send emails I get the usual "cannot connect to smtp.gmail.com" etc, but also this:
    The operation couldn’t be completed. (MCMailErrorDomain error 1046.)

    Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent.

    What gives? This is annoying me now as I'm not sure how to switch back to Pop3. I blame iMap for this, apple set it up.
     
  2. macuser292 macrumors newbie

    Joined:
    Jul 28, 2014
    #2
    Same problem here:

    MCMailErrorDomain-Fehler 1045

    Please fix.
     
  3. Cythth macrumors regular

    Cythth

    Joined:
    Feb 24, 2013
    Location:
    Lake Jackson, TX
    #3
    Everything was working now I get the same error:

    "MCMailErrorDomain error 1046"

    I hope it gets fixed soon.

    ----------

    Figured it out. If you changed your password on your account, you'll need to go into the Settings and change it for the SMTP account as well. It didn't automatically update. FYI.
     
  4. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #4
    I'm wondering if the cryptic error message is new… wasn't that the same behavior in Mavericks? If I had to update Mail to match my newly changed server password, I had to change both incoming and outgoing passwords.
     
  5. edalch macrumors newbie

    Joined:
    Oct 7, 2008
    Location:
    Alexandria, VA
    #5
    Trouble with SMTP server and Mail under Yosemite

    I tried your fix, but it didn't fix the problem. None of the SMTP accounts work and I cannot send outgoing email. The Connection Doctor window shows that IMAP accounts for Cox, Gmail, and Yahoo are all connected to the internet. Thus I have no problem receiving email. All three SMTP accounts are shown with this detail: "Trying to log in to this SMTP account failed. Verify that the username and password are correct." In addition, all my inbox accounts are offline and I haven't been able to get the computer to "Take all accounts on line." Very frustrating.
     
  6. Essex711 macrumors member

    Essex711

    Joined:
    Sep 20, 2012
    Location:
    NY
    #6
    Having the same issue, filled out the feedback assistant and sent to apple. Assume they will take care of it before the release.
     
  7. TheBuffather macrumors 6502

    TheBuffather

    Joined:
    Jul 19, 2009
    Location:
    Orlando, FL
    #7
    I have reported this bug to Apple, which they requested I double check if it's still there in the GM (which, it is). They're aware of it, but who knows how long they'll take to fix it. This is a very important part of an OS.
     
  8. frankgayer macrumors newbie

    Joined:
    Oct 3, 2014
    #8
    Hallo,

    i`m now also on GM Candidate and i have now this problem also. In the last Betas i did not have trouble sending out Emais. Is there any response from Apple or any workaround what to do ?
     
  9. Taulbee macrumors newbie

    Joined:
    Oct 13, 2014
    #9
    Resolved SMTP issues

    Hi all -

    For whatever its worth, I went through and changed the passwords for all 7 of the email accounts I use in Apple Mail, updated the settings in outgoing server dropdown menu in Mail / Preferences / Accounts / Outgoing Mail Server (SMTP): / Edit SMTP Server List . . . and that resolved the SMTP / outgoing mail issue for me. Yosemite 10.10, MBP Retina 13.
     
  10. AversaS macrumors newbie

    Joined:
    Oct 3, 2013
    #10
    Here's what I did.

    I use application specific passwords. I have to revoke my old macbook password and get a new one.

    I then took the new password, went into preferences>accounts and placed the newly generated password in the correct field.

    I then clicked outgoing mail server (smtp)>edit smtp server list>advanced and placed my application specific password into the correct field there.

    Click okay, save what you did, and that seems to have taken care of it.

    Hope this helps.
     
  11. NoBoMac macrumors 65816

    Joined:
    Jul 1, 2014
    #11
    What AversaS said.

    Something else to look out for:

    The first Mac I updated was my mother's. I have an account on there, and when I popped into my account and Mail, keychain items started flying around and one of my e-mail accounts "bricked" on my MBP. Fix was per AversA, regenerate and enter a new app-specific key.
     
  12. Roadkingscot macrumors newbie

    Joined:
    Oct 20, 2014
    #12
    SMTP mail still not working

    Hi, I updated to OSX 10.10 yesterday and ever since then none of my outgoing mail connections, using SMTP, will work. So far I have;

    1) Deleted the account passwords from keychain.
    2) Deleted the actual mail accounts from mail.
    3) Re-Added the mail accounts. This required me to resubmit the passwords which then created new keychain entries. The mail accounts then synchronised and pulled down all outstanding mail. I also checked that the same passwords were being used for the outgoing smtp connection.
    4) Even though the pop3 accounts are working for downloading any new mail the smtp connections are not working for sending any mail. This is occurring on both of my mail accounts so not sure what to try next.
    I've double checked the settings with my iphone, which is managing to send using smtp, and they appear to match.

    Anyone got any suggestions?
     
  13. Bino1970 macrumors newbie

    Joined:
    Nov 5, 2014
    Location:
    New York City
    #13
    Try Generating a new password for gmail for Mac

    I believe that someone already posted this information but I can't find the post. Nevertheless, I was having the same issue with gmail SMTP on my Mac. I knew that I had two step verification step up via gmail. So, went into my gmail security settings and created/generated a password for mail for Mac. I cut and pasted that password into gmail in the account preferences on my Mac. All is well now. I hope this helps.
     
  14. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #15
    I'm experiencing issues with POP3 email as well. Primarily the issue is with gmail, but also with accounts from Cox Communications. My issues started with the beta of 10.10.3, but is serious, nonetheless.

    I emailed Craig Federighi about this and got the following response. Even though he specifically singles out Google/gmail, I am also having some issues with other email providers (as stated above).

    I asked him point-blank if Apple Mail was moving away from support for POP3. His response:
     
  15. MovingWater macrumors newbie

    Joined:
    Oct 29, 2010
    Location:
    Canada
    #16
    These are rather detailed instructions for what worked for me. I now can finally send securely, authenticated and reliably, in 10.10.3

    Part 1: Clear out Apple Mail settings

    1. Open Mail -> Preferences
    2. Under "Accounts", go to the email account for which the SMTP connection can not be established.
    3. Under "Advanced", un-check "Automatically detect and maintain account settings"
    4. Under "Account Information", go to "Outgoing Mail Server (SMTP), and choose "Edit SMTP Server List..."
    5. Under the SMTP Server List, remove the SMTP servers that are not working, by clicking the minus sign.
    6. Close the SMTP Server List by clicking "OK."
    7. Verify the Outgoing Mail Server (SMTP) entry is set to "None".
    8. Close Apple Mail

    Part 2: Clear out Keychain settings

    1. Open the app "Keychain Access"
    2. Choose the "iCloud" Keychain in the left menubar
    3. Click on "Kind" the list of entries by kind
    4. Carefully go through the list of items of kind "Internet password." Go through the list one by one, and look for the ones that have "Where: smtp://..."
    5. Remove internet password entries that are SMTP connections to the server you cannot connect to.
    6. Do this slowly so you don't accidentally remove wrong entries.
    7. Close Keychain Access

    Part 3: Start with a clean slate

    1. Restart the computer
    2. Close down virus checking software
    3. Close down any running apps for monitoring connections, such as Little Snitch and Hands Off

    Part 4: Re-establish an SMTP connection

    1. Open Apple Mail
    2. Go to Apple Mail -> Preferences -> Accounts again
    3. Click on the account for which SMTP is not functioning
    4. Under "Account Information", go to "Outgoing Mail Server (SMTP), and choose "Edit SMTP Server List..."
    5. Create a new SMTP server by clicking the plus sign.
    6. Under "Advanced" un-check "Automatically detect and maintain account settings.
    7. Type in the SMTP information that you know should work.
    8. Press "OK"
    9. Verify "Outgoing Mail Server (SMTP)" has selected the correct server.

    Part 5: Keychain entry

    1. A pop-up window pops up, asking you to trust a certificate.
    2. Carefully note down the name of the certificate. In my case, the certificate was issued by Comodo
    3. You must trust this certificate.
    4. Open Keychain Access
    5. Find the new certificate under the "Certificates" menu.
    6. Click on the certificate
    7. In the certificate, click on the "Trust" triangle to open the trust section.
    8. Set the following three entries to "Always Trust": "Secure Sockets Layer (SSL)", "Secure Mail (S/MIME)", and "X.509 Basic Policy". Leave the other entries at "no value specified"
    9. Close the certificate window
    10. Close the Keychain Access app

    Part 6: Check if it works in Apple Mail

    1. Open Apple Mail
    2. Open Window -> Connection Doctor
    3. Mine finally showed "Connection and login to server succeeded." Hurray.

    Key points:
    * Make sure mail settings are not synchronized
    * Don't run Little Snitch or Hands Off while you set this up
    * Use both Apple Mail and Keychain Access app while setting this up
     
  16. ankeet_bhat macrumors newbie

    Joined:
    Jun 28, 2015
    #17

    @MovingWater - you're awesome man. Thanks so much for the list of steps. It worked like a charm for me. I was almost handicapped for a month (I receive few hundred emails a day) & was using my iPhone mail client + Thunderbird (which pretty much sucks) Lol.
    Thanks again.

    Not that I understood in depth what your steps did but out of curiosity I wanted to know what the root cause is. Was it Key Chain ? & how was Key Chain affecting the settings of an smtp server ? Clearly the issue is with the mail client in OS X. It would be awesome if you could throw some light on how the chain of events led to the smtp server not working & getting fixed.

    Thanks a ton again !
     
  17. MovingWater macrumors newbie

    Joined:
    Oct 29, 2010
    Location:
    Canada
    #18
    You're most welcome! It is a certificate issue. I think it's Apple Mail that is causing the problem, and not Key Chain. I had the same problem as you for a while. I then installed vanilla Mailbox.app and Postbox.app (neither of which I had previously installed), and I studied how they each interacted with the Key Chain and how they handled credentials and authentication. The idea was then to mimic inside Apple Mail how Mailbox.app and Postbox.app handled certificates. The solution was to hardcode Apple Mail to trust and use a specific certificate. My description of the fix is a bit long because I wanted it to work for everyone, no matter their current state.
     

Share This Page