Trouble with SSH after getting Airport Extreme

Discussion in 'iPhone Tips, Help and Troubleshooting' started by insocal, Nov 21, 2007.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    I had no problem with my old Netgear router using FUGU or CYBERDUCK.

    Now I have an APPLE Airport Extreme Basestation and it gives an odd IP Address...it's 10.x.x.x or something rather than the usual 169.x.x.x

    It always refuses the connection to the iPhone.

    Is there a fix to this?

    Thanks so much!
     
  2. oseary macrumors member

    Joined:
    Sep 12, 2007
    Location:
    Columbia, MO
    #2
    10.*.*.* is the default scheme pushed out by the Airport Extreme. Or at least it was with mine... You can change it in the Airport Extreme setup, in your utilities area... I changed mine to push out the 192 scheme, since I was hooking my 360 up to it, and wanted to avoid any MS related issues...

    Try changing it to the 192 scheme (it's an option in the dropdown menu), and see if that helps.
     
  3. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #3
    You probably hardcoded the old ip address in your settings somewhere.

    If needed, you can probably reconfigure the Airport Express so that it provides 192.168.x.x adresses.

    Both 10. and 192.168 are private adresses that are typically assigned to the internal part of the network.
     
  4. insocal thread starter macrumors regular

    Joined:
    Jul 31, 2007
    #4
    Okay, so I've changed that IP address on the base station which now gives the iPhone 192.168.1.198 but the connection is still refused when using FUGU and Cyberduck gives an error message as well.

    This never happened before so I'm a little confused. Any other help would be greatly appreciated!

    Thanks!
     
  5. insocal thread starter macrumors regular

    Joined:
    Jul 31, 2007
  6. magneticboy macrumors newbie

    Joined:
    Apr 25, 2008
    #6
    How did you fix it?

    Insocal, I have been suffering the same problem with SSHing my iphone. I had connected previously but for some reason have been unable to in the past week. Ive searched many a forum and tried the majority of the advice on offer but to no joy.
    What did you do in the end to fix your airport issue. Im curious as to whether it would fix my problem too.

    Thanks in advance for your time.
     
  7. klor macrumors newbie

    Joined:
    Sep 30, 2008
    #7
    hello there, i've been suffering the same problem and given that i just found out how to solve it i just thought i'd share... i did install OpenSSH from Cyndia.
    and it didn't work. When i was on 1.1.4 etc, everything worked fine, now i'm running 2.1 and i couldn't SSH my iphone even though i had OpenSSH installed. I just found out that the OpenSSH from Installer is different than OpenSSH from Cyndia and this morning i just installed the one from Installer and everything is working again! hope this helps. bye!
    :)
     

Share This Page