Trouble with the function keys on bluetooth apple keyboard (aluminum)

Discussion in 'Mac Basics and Help' started by ProstheticHead, Nov 6, 2009.

  1. ProstheticHead macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Seattle, WA
    #1
    So I recently received a bluetooth ultra-thin keyboard to use with my laptop while I have it hooked up to it's external monitor, the only trouble is that I can't seem to get the function keys to work properly. I've managed to go in and reset the dashboard control / brightness using the keyboard pane in the system settings, but I can't seem to set the volume / media control buttons. Any ideas how to get my keyboard working properly? If it matters at all, I'm running this on a 2.4 unibody MBP.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
     -> System Preferences -> Keyboard & Mouse -> Keyboard -> Use all F1, F2, etc. keys as standard function keys.
     
  3. ProstheticHead thread starter macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Seattle, WA
    #3
    No go. With that checked regardless whether I hold down the fn key or not the volume control is still non-responsive.

    Frustrating that it'll recognize all of these commands on the built-in keyboard, but not on Apple's own wireless external.
     
  4. funaki macrumors newbie

    Joined:
    Nov 7, 2009
    #4
    aha

    same problem here... In other forums, others posted having the same problems...

    I guess apple needs to come up with a patch/update on the driver software? :confused:
     
  5. ProstheticHead thread starter macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Seattle, WA
    #5
    FOUND A FIX.

    Download and install the Magic Mouse Software Update from Apple. I think it's called the Wireless Mouse Software Update.

    Fixes the entire issue. Somewhat ridiculous, but it works.
     
  6. funaki macrumors newbie

    Joined:
    Nov 7, 2009
    #6
    Somewhat desperate here....

    Doesn't work. Installed Magic Mouse drivers twice.

    I have OS 10.5.8, Magi Mouse and the new apple keyboard... but the function keys don't work, no matter if I tag the checkbox or not. I can't alter volume, brightness etc.... :confused:

    Grateful for any other advice...
     
  7. funaki macrumors newbie

    Joined:
    Nov 7, 2009
    #8
    thx! it works perfectly now. :)

    (what took them so long...) :(
     

Share This Page