Trouble with the Keychain

Discussion in 'Mac Apps and Mac App Store' started by mattluc, Nov 14, 2008.

  1. mattluc macrumors member

    Joined:
    Oct 28, 2008
    Location:
    York, PA
    #1
    I recently had to do a restoration for my 1st gen. MBP with 10.4.11 and i did so not only with "Users", but also with the "Library" and "Applications" folders. I seem to have smoothed out most kinks, but i still have one issue i'd like help with:

    Whenever i boot or wake up my computer or turn airport on (i do have to turn it off sometimes, not an issue though), i get this message:

    [​IMG]

    I know my password and it works for everything else (installing programs, etc.), but no matter what i enter on this it always tells me it's incorrect. If i give up and press 'Cancel', everything seems to function fine (airport will select a preferred network, for example). Still annoying, though.

    I went to Keychain Access and i am capable of unlocking the 'System' keychain (as you can see in this screenshot) using my password. But there are 2 of them...

    [​IMG]

    My guess on this issue is that my computer is trying to access both of these 'System' keychains at once and that's the conflict. However, i can't delete either keychain OR anything in them!

    [​IMG]

    :confused::confused::confused:
     
  2. mattluc thread starter macrumors member

    Joined:
    Oct 28, 2008
    Location:
    York, PA
    #2
    First i went to the preferences for Keychain Access and did the "repair keychain" thing twice (once for each "System" keychain). The problems were still there even though there was only one "System" keychain now. Eventually i decided to delete System.keychain from ~/Library/Keychains, which i do have backed up. This fixed the main symptoms of this issue, because network passwords and the like are saved in the "login" keychain.

    I posted a new thread regarding the ramifications of deleting that file. It is available here: http://forums.macrumors.com/showthread.php?p=6721556#post6721556
     
  3. mattluc thread starter macrumors member

    Joined:
    Oct 28, 2008
    Location:
    York, PA
    #3
    Oh, and on a humorous note, the first time i did that repair thing in Keychain Access, i got this message:

    [​IMG]

    I laughed.
     

Share This Page