Troubles getting 2006 MacBook Pro to work with Intel SSD

Discussion in 'MacBook Pro' started by bazookafx3, Dec 1, 2010.

  1. bazookafx3 macrumors regular

    Joined:
    Jan 17, 2008
    #1
    Hello there everyone,
    It's been a while since I was last here but I've come to you guys requesting some help.

    I have a 2006 MacBook pro that I've been trying to install a new Intel X18-M 80Gb SSD in, to no avail.

    The main problem is that when I pop in the Leopard installer and boot up into it, the disk is not recognized by Disk Utility or even in System Profiler, same thing happens when I connect the SSD via USB while running OSX.

    I know the drive is not dead as I can see it in Windows and use it perfectly. I've tried formatting it to NTFS, FAT32, and HFS+ then putting it in the MacBook but it still refuses to see it. I made sure to set it as a GUID partition and I still see nothing in the Installer or even OSX.

    I know the drive is SATA II standard (3Gb/s) and my MacBook only has SATA I (1.5Gb/s) so I'm not sure if that means it's a lost cause or if I can do anything about it.

    Any help would be appreciated, thank you.
     
  2. Saturdays macrumors member

    Saturdays

    Joined:
    Nov 18, 2010
    Location:
    Somewhere in USA
    #2
    Have you tried upgrading firmware?

    Other than that, I see no reason why it won't work on yours, SATA 3.0gb/s should fall back on 1.5gb/s if 3.0 isn't available.

    I would try formatting it with GParted, though it may not be the solution its a powerful tool to manage disk drives and it may clear some sort of inconsistency.
     
  3. bazookafx3 thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #3
    I actually have tried to upgrade the firmware but it tells me I have a "Pre-production firmware" and refused to let me upgrade.

     
  4. bazookafx3 thread starter macrumors regular

    Joined:
    Jan 17, 2008

Share This Page