Troubleshooting a USB-Ethernet adaptor issue

Discussion in 'Mac Accessories' started by GanChan, Oct 13, 2016.

  1. GanChan macrumors 6502a

    Joined:
    Jun 21, 2005
    #1
    I've been using a fairly standard-issue Belkin USB-to-Ethernet adaptor with my 2013 Macbook Air (running Mavericks) for a couple of year now, and it's always worked fine. In the past over of weeks, however, I've been experiencing spotty Internet connectivity while using it.....Here's what I know so far:

    • Sometimes the lights on the unit will go off, as if the physical connections were incomplete, even though the connections on both ends seem firm enough.
    • The Macbook ports seem to work fine when I plug in other devices.
    • The Ethernet router and cable modem appear to be functioning normally.
    • The Ethernet cable is less than a year old and isn't showing any outward signs of wear.
    • The Belkin seems to work fine when plugged into my Chromebook, although I may need to try this for longer periods to see if I can get the problem to occur on this computer.

    The problem is hard to replicate and highly unpredictable, apparently occurring at will. I'm usually working with no other applications apart from Chrome and Dropbox at the time of operation.

    The Belkin does get pretty hot when it's been running a while. It always has. Normal?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Have you tried to Reset Your PRAM because sometimes it helps to reset the ports in your Mac?
     

Share This Page