Troubleshooting kernal panics on 12" G4 Powerbook 1.5ghz

Discussion in 'PowerPC Macs' started by macheyb, Jul 31, 2011.

  1. macheyb macrumors newbie

    Jul 31, 2011
    Hi All,

    I bought the above over 5 years ago and have never experienced a single issue with it until very recently. I was browsing the internet when bands of black started moving down the screen and I was faced with a Kernal panic.
    On restarting the computer I was faced with a black screen even thought other actions completed (Chime, HD spin up, lights worked on capslock and numlock keys)

    I’ve tried to narrow down what the issue could be by a number of measures however haven’t been successful hence my post here.
    Here is what I’ve tried so far;

    Apple Hardware Test (AHT) (Press option key on boot) – Seemed to work first time I ran it but has’t worked since. Displayed a grey screen with a macinotsh HD icon in centre of screen, two arrows displayed below, one pointing to the right and one in a circle. I pressd the arrow on the right which loaded the account log on screen, which then froze.

    Install from OSX discs (insert disc, hold C) – Didn’t seem to do anything

    Reset PRAM and VNRAM – resetting the ram worked but didn’t have any affect on main issue.

    Removing ram and booting – computer boots and seems to work but keral panics appear after a few seconds.

    I’ve resently bought some new ram (1GB DDR 333mhz PC2700) so this may have caused the above however on installing it the computer seemed to register it and it ran fine for 2 weeks +.

    Any ideas on a possible resolution would be much appreciated, please ask if you require any further information.

    Many Thanks,

    Attached Files:

  2. bizzle macrumors 6502a

    Jun 29, 2008
    Looks like GPU failure from the pictures. I'd fairly common for a loose Airport card on a 12" to cause all sorts of issues but usually not graphical corruption. For the sake of being thorough, reseat it.
  3. ViviUO macrumors 6502

    Jul 4, 2009
    AHT doesn't always catch everything. I would run memtest immediately.

    My 1.33ghz 12 inch PB recenty started suffering kernel panics as well. AHT couldn't tell me what was wrong, memtest came back fine as well. Turns out my HDD was dieing. After replacing it, I have no more problems.

Share This Page