Troubleshooting Local Apache 404

Discussion in 'Web Design and Development' started by datrandkidz, May 18, 2014.

  1. datrandkidz macrumors newbie

    Joined:
    May 18, 2014
    #1
    http://mallinson.ca/post/osx-web-development/ -- trying to follow this guide (and comments for troubleshooting)

    My system has an SSD (boot drive, applications, libraries, etc.) and an HDD for primary file storage (called "Storage"). I read through the comments and realized that since I'm using /Volumes/Storage/www rather than /www, I must make a couple changes in the httpd.conf (add path leading up to /ww) and httpd-vhosts.conf (change directory on lines 169 and 197) to match my directories.

    Accessing localhost has been showing a "It works!" from the start. Before making these changes, I was receiving a 403 error when going to home.dev/ or *.dev/ for that matter. After making these changes, I seem to be receiving a 404 error instead. I tried adding a simple index.html in /Volumes/Storage/www/sites/home/wwwroot, but this didn't seem to help as the 404 remained. Note that I haven't gotten to the stage of using the local homepage script yet.

    Here are the important files:
    dnsmasq.conf -- http://pastebin.com/LtRc2Spb
    hosts -- http://pastebin.com/0U0KEpAZ
    httpd.conf -- http://pastebin.com/ZGGrY1Nn
    httpd-vhosts.conf -- http://pastebin.com/xFzt0u4U
    DNS Network Settings -- Attached PNG

    Would someone provide (a) solution(s)? I'll test it and tell you if it worked, and we'll go on from there. Please respond ASAP. Need to get some projects up locally over the next few days.
     

    Attached Files:

  2. JoelTheSuperior macrumors 6502

    JoelTheSuperior

    Joined:
    Feb 10, 2014
    Location:
    London, UK
    #2
    Apologies in advance if I've missed something obvious but two main things I would check:
    1. Is the storage volume mounted?
    2. Does Apache have read/write access to the folder you're pointing it to?

    Something you can test is just to make sure that the path works using Go -> Go To Folder in Finder.

    It most certainly won't be a DNS issue or similar, it is most likely is just down to your Apache config.
     
  3. datrandkidz thread starter macrumors newbie

    Joined:
    May 18, 2014
    #3
    1. I believe it is mounted. It's a 2nd hard drive (HDD). I have an HFS+ SSD boot disk and ExFAT HDD.

    2. This is where I'm a bit confused. How would I check? Get info just says I can read and write in text without option to change as ExFAT works differently.'


    How do my configuration files look?
     

Share This Page